Kawasaki Ninja ZX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
SOMEBODY HELP!!!!! I sure hope this isn't a major deal, but my ZX9 wont start. I initially thought the fuel pump was not working, but I by-passed the relay and supplied power straight to the pump to find that it does work, and tells me my fuel pump relay is bad. After bypassinig the relay I removed the fuel line from the fuel rail to ensure the pump was pushing fuel through, which it is. Now it seems the fuel is getting up to the fuel rail, but no further. What could this be????????

I removed the air filter, and put gas directly into the carbs, and it ran fine until that fuel burned off. Other than the relay being bad, what would stop the fuel from getting to the carbs to keep the engine running???
 

·
Premium Member
Joined
·
4,271 Posts
stuck floats, blocked jets
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
Thx Slim. Im going to try, and check the floats, and jets tomorrow, and see what happens.
 

·
Registered
Joined
·
15 Posts
Did yours pulse out of the line or did it have a steady flow with the factory harness plugged? Trying to check on one of my problems.
 

·
Registered
Joined
·
16 Posts
I have a 01 zx9 that I recently picked up..the bike will crank but wont turn over..the gentleman i bought the bike from said the carbs were gummed up but when I took the bike to a mechanic he said the carbs are fine it is something electrical.the battery was charged the bike has good compression..however the mechanic said the spark was weak..what should he check..I heard it could be the CDI box, coils plugs, etc. What test can he do to find the issue..I don't want to buy all these parts and not need them or can't return them...sorry for the long post..need help!!! NOOB!!!

Sent from my LT28at using Motorcycle.com Free App
 

·
Registered
Joined
·
3,145 Posts
I have a 01 zx9 that I recently picked up..the bike will crank but wont turn over..the gentleman i bought the bike from said the carbs were gummed up but when I took the bike to a mechanic he said the carbs are fine it is something electrical.the battery was charged the bike has good compression..however the mechanic said the spark was weak..what should he check..I heard it could be the CDI box, coils plugs, etc. What test can he do to find the issue..I don't want to buy all these parts and not need them or can't return them...sorry for the long post..need help!!! NOOB!!!

Sent from my LT28at using Motorcycle.com Free App
Thread Jacked LOL

Might as well start hoarding parts so that you can replace the faulty part upon repair time instead of waiting for a part to come in. If its electrical then you need to start replacement of the simple things in the "pyramid". Start with plugs, plug wires, coils, battery, leads from wiring harness, junction box/cdi box.
 

·
Registered
Joined
·
2,420 Posts
RKW, I would start checking the battery first, then the wiring connections from the battery to the starter motor, the start switch, then the junction box...
 

·
Registered
Joined
·
2,420 Posts
SOMEBODY HELP!!!!! I sure hope this isn't a major deal, but my ZX9 wont start. I initially thought the fuel pump was not working, but I by-passed the relay and supplied power straight to the pump to find that it does work, and tells me my fuel pump relay is bad. After bypassinig the relay I removed the fuel line from the fuel rail to ensure the pump was pushing fuel through, which it is. Now it seems the fuel is getting up to the fuel rail, but no further. What could this be????????

I removed the air filter, and put gas directly into the carbs, and it ran fine until that fuel burned off. Other than the relay being bad, what would stop the fuel from getting to the carbs to keep the engine running???
A kinked fuel line, is mostly the culprit in these cases.
 
1 - 8 of 8 Posts
Top