Kawasaki Ninja ZX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello all, new to the forum and having some issues with my zx7.
Bought the bike as a none runner and been laid up for 5 years.
It’s a 1997 UK bike 29000 on the clock aftermarket headers standard end can BMC air filter everything else appears to be standard.
After a carb clean new spark plugs CR9EK(off eBay) fresh oil it fired straight up.
While it was stripped down I did the float bowl mod and went for 150 160 160 150 mains 2 turns out on the air screw.
Took it out for a test ride and ran like crap the more I rode it and the warmer it got the worst it got to the point where it would cutout when coming to a stop and wouldn’t restart until cooled down then wouldn’t start at all changed plugs to CR9E from a trusted retailer fired straight up took it back out ran fine to start with then same again.
Checked for vac leaks doesn’t appear to be any.
Is possible for something electrical to burn out the plugs or do the carbs need looking at again?
Any help would be much appreciated.
Thanks in advance.
 

·
Registered
1993 Zx-7 L Model, 2006 ZX-10R
Joined
·
3,277 Posts
Sounds like it's running rich
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Ok, thanks for reply.
I’ll try going in on the air screw and see how things go.
What else would lean it out?
 

·
Premium Member
Joined
·
2,477 Posts
If it gets worse when hot, it is definitely running rich. Leaking float valves? Fuel level/ float height? Jetting? This is the order I would check.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Float valves checked and not leaking
Float height is 14mm
Jetting is 150 160 160 150 mains
Do I need to change pilot jet size?
Couple of other things to mention is
Inside the oil filler cap and spyglass the oil looks like Mayo also when I was setting up the carbs I ran it on a dummy tank (clear plastic bottle) which was sat up on the tailpiece and over a period of time the fuel would darken with oil contamination.
Could a blown head gasket cause the problems?
I put the whitening of the oil down to it being stood for so long but I put fresh oil in before starting it and have no idea how oil could get all the way back up to the dummy tank.
 

·
Registered
1993 Zx-7 L Model, 2006 ZX-10R
Joined
·
3,277 Posts
Float valves checked and not leaking
Float height is 14mm
Jetting is 150 160 160 150 mains
Do I need to change pilot jet size?
Couple of other things to mention is
Inside the oil filler cap and spyglass the oil looks like Mayo also when I was setting up the carbs I ran it on a dummy tank (clear plastic bottle) which was sat up on the tailpiece and over a period of time the fuel would darken with oil contamination.
Could a blown head gasket cause the problems?
I put the whitening of the oil down to it being stood for so long but I put fresh oil in before starting it and have no idea how oil could get all the way back up to the dummy tank.
Milky oil can happen from it sitting for a long period of time. I have a salvage motor with this issue. I've been told that after I change the oil in it, to put about 1000mi on it to give the motor a chance to evaporate the moisture that has collected inside.Then change the oil again.

When the bike is idling, you have white smoke out of the exhaust or a bluish grey smoke?

Your idle jets don't affect ride-ability. That's going to be your main jets and your jet needle height. Do you know if this bike has the Kleen air mod done to it?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Yes I think so.
Reed valve covers T into each other
Vac lines blocked off
Float bowl pipe into air box
Other air box hole at the front blocked off, is that correct?
 

·
Registered
1993 Zx-7 L Model, 2006 ZX-10R
Joined
·
3,277 Posts
Yes I think so.
Reed valve covers T into each other
Vac lines blocked off
Float bowl pipe into air box
Other air box hole at the front blocked off, is that correct?
Can you be more specific about this airbox hole at the front blocked off? I hope you're not talking about the ram air snorkle
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
No I’ve not blocked the ram air off,
The one that goes to the intake silencer.
If a bikes running rich will it destroy the spark plugs?
Reason I ask is the set of plugs from eBay only lasted 5 minutes so it may of been the fact they were fake,
The second set which are genuine seem to last a bit longer but the bikes acting the same with them in.
Apart from screwing in the air screw is there anything else to lean it out?
 
1 - 9 of 9 Posts
Top