Kawasaki Ninja ZX Forum banner

261 - 280 of 286 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter #261
Hello!

Problem solved! Lack of fuel was caused not by restriction on feeding line on injectors rail, but by improper fuel pressure. Fuel pressure regulator was broken. With new one and proper 3 bars of pressure I got Steady 12,5:1 AFR up to redline (11500rpms). Now it works like a charm.
Tomorrow I will post new screenshots from datalogging. :)

BR

Kuba
 

·
Registered
Joined
·
153 Posts
Discussion Starter #262
Hello :)

Here's a screenshot of datalogs from full throttle run :) Seems to be running quite perfect, AFR 12,8:1 at top end is really safe. Now there's only one last task to do... dyno and fine iginition tuning :)

 

·
Registered
Joined
·
153 Posts
Discussion Starter #266
Hello.

Currently I'm running on Ecumaster EMU (since two new versions were introduced, my version is called EMU Classic)
Bike runs wasted spark ignition (coils from zx6r), bank injection (GSXR throttle bodies and injectors).
I'm using stock ZX7R crank sensor with 24-2 teeth wheel (coming from er6n... or something similar, I'm not sure about that but I can check it).
Rest is pretty much standard IAT sensor, MAP sensor (built in EMU), CLT sensor, stock TPS sensor from GSXR, wideband lambda sensor (Bosch LSU 4.2).
Logs are coming from DL1 - it's datalogger dedicated for EMU, logs data on SD card and it also allows bluetooth connection with android devices to display realtime parameters on EMUDash.

That's short description of my current setup.

BR

Kuba
 

·
Registered
Joined
·
153 Posts
Discussion Starter #268
Hello rsr,

If you got some question regarding EMU, feel free to ask here. I will try to answer all of them. It might be useful for other forum members.
I will be happy to help.


BR

Kuba
 

·
Registered
Joined
·
405 Posts
looking at the "EMU Black" software now

One question I have for you is: are you using a secondary trigger or do
you have 2nd trigger (setup: Trigger Type / Do not use cam snyc) selected (or similar)

I saw on you primary trigger you have 24 -2 wheel or ? sometimes choice is limited

As I understand you are running inj's batched and waste spark COPs config
thinking full sequential might be a good idea in future with 2nd trigger installed
cam cover mounted or ? location/triggering @ 1/2 crank rpm

also wondering if you have looked at possible injector saturation and
COP / dwell, saturation of the Kawi coils? maybe too early to ask that
"might" show up as issue once sorting on dyno or datalog runs
 

·
Registered
Joined
·
153 Posts
Discussion Starter #270
Hi rsr,

I don't use secondary trigger, do I have set "do no use cam sync". In my opinion it's useless to have sequential injection on high reving engine. Injectors "open windows" will overlap themselves and you will loose all of your sequential advantages. Too much of effort.
I'm using only crank trigger sync with 24-2 teeth. With 24-1 i have had some problems with with revs... it was loosing sync, so I've switched to 24-2 due to larger sync gap.

I've didn't catch your point regarding "saturation", but...
At the begining I've measured injectors opening times at various supply voltage to have proper injectors dead times and I've did the same with coil to have poperly set dwell time, to not overheat colis and have a nice spark energy.

Hope that those answers are clearing out some doubts regarding my project and setup.

BR

Kuba
 

·
Registered
Joined
·
405 Posts
questions answered > you did your home work on project > Good Job

thinking here of trying/using a "Black" on next Porsche project
that comes around if it's a local car vs Motec , need to talk to USA EMU guy
at PRI first but all looks good "on paper" so far

I'll keep watching this thread and help pitch in as needed > Thanks
 

·
Registered
Joined
·
153 Posts
Discussion Starter #272 (Edited)
Hello rsr,

Which Porsche engine you will use in your project? Asking just for my curiosity. I've been playing a lot with GT3 cup Porsches.
I've been a great fan of Motec, but it was really log ago... M800 or M880 were good ECUs but now they're expensive option comparing to other ECUs.
One of my favourite ECUs was Pectel SQ6 but every single additionaly option like antilag, traction control, DBW was paid separatly. So old respected standalone makers are starting to be not so attractive comparing to "new" ECUs which were introduced during last few years.
When Pectel and Motec 7-8 years ago started to be expensive (in comparison to others) I've switched to Link ECU or Vi-Pec. Honestly speaking, I've found them as functional as Motec, without need to pay for each additional option.

ECU for your project should be nice fitting your requirements, you need to decide do you need only engine controller or you also want to combine power management etc.

BR

Kuba
 

·
Registered
Joined
·
405 Posts
Next for "possible" EMU Black is 3.2 Carrera with nothing too crazy in engine
dept. rods, twin plug, heads worked on, 964 cams maybe, throw all the Motronic
stuff in the bin

been around a lot of the "Cup" stuff and GT3's, more and more of these are showing
up in vintage racing and the Porsche / Bosch Motorsport "Locked out" ECU's are being
swapped out to Motec M800/M880 or similar capable ECU's, Porsche Motorsport sells an
"unlocked" ECU for the early cup cars at a real stupid price

noticed in an earlier post you were around some F3 stuff ? was that before McLaren
took over the electronics for the sanction
 

·
Registered
Joined
·
28 Posts
Hello

Ecumaster DET3 is so nice device... that it's able to work as fuel standalone. So DET3 is enough to provide a proper fueling :)

BR

Kuba
I thought piggybag means you need an existing ecu to add on?

Did i get it right: You use sensors, throttlebody, gas pump wo2 and connect it directly to the DET3 ? Would love to get a deeper introduction in this...
Hello
Sorry for the late reply, the ZXR engine bracket was broken from the frame so I had to dismantle the whole bike and weld the body.
Kuba had already answered this but yes, throtle body is 2000-2003 750-1000 GSXR. TPS, ECT, IAT and W02 what I use just setup what is still badly involved.
The ignition is original, but the signal goes through DET3 to the ignition unit. This is perhaps a problem because DET 3 seems to be coming out of an unipolar signal even though bipolar goes in.
The original signal is also quite strange so this may be due to it.
Maybe I could leave the signal on the original ignition unit and connect in parallel to DET 3.
I look at it in time.
Hopefully I will find the time and motivation to complete the project.

edit: Ignition signal coming out bipolar just like it should but cranking revs are too slow so output signal is too low --> no spark.
ZXR ignition unit give only 1,5V to sensor, maybe it's because of this.
 
261 - 280 of 286 Posts
Top