Kawasaki Ninja ZX Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1 (Edited)
ok guys. my t-rex is now back to a stock motor and no more turbo :(

my goals are to get it running n/a perfect this year and then returbo it on the stock motor with LOW BOOST this time so she stays together...


heres whats going on..

between 2-4K. it stutters while going through the rpm's

like this..
waaaaaa p p p p p p p p p p p p p p p p waaaaaaaaaaaa... shift..

^not bad huh? lol

any ideas? its on the stock ecu un tuned.. I have a power commander 5 laying around, should I remove the butterflies and just get it tuned???

also because my fuel rail has been converted to return setup and I have a Adj. FPR on it. what fuel pressure should I keep it at?
 

·
Quinton Phuckin Tarantino
Joined
·
18,914 Posts
ok guys. my t-rex is now back to a stock motor and no more turbo :(

my goals are to get it running n/a perfect this year and then returbo it on the stock motor with LOW BOOST this time so she stays together...


heres whats going on..

between 2-4K. it stutters while going through the rpm's

like this..
waaaaaa p p p p p p p p p p p p p p p p waaaaaaaaaaaa... shift..

^not bad huh? lol

any ideas? its on the stock ecu un tuned.. I have a power commander 5 laying around, should I remove the butterflies and just get it tuned???

also because my fuel rail has been converted to return setup and I have a Adj. FPR on it. what fuel pressure should I keep it at?
the stock fuel pressure is supposed to be 44psi. I would start by setting that. has the ecu been reflashed? have any of the components been replaced for turbo use (for example the map sensor sometimes gets replaced to sense not only vacuum but also boost)?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #3 (Edited)
the stock fuel pressure is supposed to be 44psi. I would start by setting that. has the ecu been reflashed? have any of the components been replaced for turbo use (for example the map sensor sometimes gets replaced to sense not only vacuum but also boost)?
hm ok Ill def adjust the fuel pressure down.

the Ecu is from the new motor. I bought the motor from a yard, it came with the ecu and was told that I should keep the ecu/engine together as its from a 2008 and there are very minor differences.. the bike was wrecked with 1100 miles on it and was a bone stock engine. not even a pipe on it.

I am unsure about the Map sensor but I can easily get a new one just to make sure.
 

·
Registered
Joined
·
141 Posts
could be a million different things...with what you have done to it, its going to be a trial and error thing until you figure it out...
 

·
Quinton Phuckin Tarantino
Joined
·
18,914 Posts
hm ok Ill def adjust the fuel pressure down.

the Ecu is from the new motor. I bought the motor from a yard, it came with the ecu and was told that I should keep the ecu/engine together as its from a 2008 and there are very minor differences.. the bike was wrecked with 1100 miles on it and was a bone stock engine. not even a pipe on it.

I am unsure about the Map sensor but I can easily get a new one just to make sure.
Fuel pressure too high makes sense for the problem you are having because at lower rpm it would squirt too much fuel and cause a stumble till the rpms pick up and it clears itself out . Hope its that simple but keep us posted .
 

·
Registered
Joined
·
75 Posts
Discussion Starter #6
Fuel pressure too high makes sense for the problem you are having because at lower rpm it would squirt too much fuel and cause a stumble till the rpms pick up and it clears itself out . Hope its that simple but keep us posted .
thank you. i will adjust it tomorrow and see where I go from there. def going to get new plugs.
 

·
Registered
Joined
·
1,466 Posts
one of the things it could be is a bad coil. i know i always mention that, but i had one go bad and it was a pain in the ass trying to figure it out for a month and it took 30 seconds to use an ohm meter and test them.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #8
well my fuel pressure was way off. it was set to 25psi... no clue wtf why. but I turned it up to 45psi. threw new plugs in it, she idles a LOT better. I did not get a chance to take it out. hoping sunday it will be nice out and I can get these bugs worked out.

my fuel filter is making a horrible tapping noise.. I thought it was hitting something but its tapping.. almost like a rod knock but its coming from inside the fuel filter, put ur hand on it and you can actually feel it hitting interally.... any ideas?? just replace the fuel filter and see what happens?
 

·
Quinton Phuckin Tarantino
Joined
·
18,914 Posts
well my fuel pressure was way off. it was set to 25psi... no clue wtf why. but I turned it up to 45psi. threw new plugs in it, she idles a LOT better. I did not get a chance to take it out. hoping sunday it will be nice out and I can get these bugs worked out.

my fuel filter is making a horrible tapping noise.. I thought it was hitting something but its tapping.. almost like a rod knock but its coming from inside the fuel filter, put ur hand on it and you can actually feel it hitting interally.... any ideas?? just replace the fuel filter and see what happens?
Replacing the filter would be a good start , if It's clogged check your gas tank .
 

·
Registered
Joined
·
75 Posts
Discussion Starter #10
Replacing the filter would be a good start , if It's clogged check your gas tank .
well changed the fuel filter and I get the same noise. new pump.. same noise but a little louder.. going backwards..

on the plus side.. raising the fuel pressure made a drastic change. no more crappy idle. she fires right up and idles. revs and drives MUUUUUUUCH better. also threw new plugs in it just to be safe. seams to be almost ready for the road!!

now just gotta get this tapping/clicking fuel pump figured out. got to bleed the brakes more, slightly adjust the rear tire and I think its ready!!
 

·
Quinton Phuckin Tarantino
Joined
·
18,914 Posts
Sounds good keep us posted
 

·
Registered
Joined
·
75 Posts
Discussion Starter #12
WTF. this is the most retarded setup I have ever come across... the idiot that put two fuel pumps in this thing. 1 (stock) inline pump... then up the fuel line about a foot.. it has a gallon sump system with a walboro pump... then it goes to the adjuster.. then to the rail.. and has a return.. but it goes into the sump... not back into the actual fuel tank...

whats causing the stock fuel pump to click is its trying to push fuel through. but its blocked because the sump is filled with fuel.. wtf was this guy thinking... this is the one of the top 5 stupidest things I have ever seen...
 

·
Quinton Phuckin Tarantino
Joined
·
18,914 Posts
So now you must add a third pump to empty the sump quicker:rotflmao
 
1 - 13 of 13 Posts
Top