Kawasaki Ninja ZX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
Hi guys,
I am new at this side of the forum but have a few posts in 7R forum as I have built my ZX7/10R using D7F motor & architecture

now I would really appreciate your thoughts - I am experiencing the "will not rev past...." problem as described in the title without any fault code shown on a display

basically my bike will not:
1) rev past approx. 9000 rpm while in standstill in neutral
2) rev past 4000 rpm while on the move - it just dies and doesn't come back to life until revs are not down to approx. 2000 rpm
3) it's not showing any fault codes; I used to get FI code 25 - gear position sensor - cured by replacing the sensor
4) I have by-passed side stand switch - no cure of the problem
5) I have replaced spark plugs as there seemed to be a problem with one while cold starting - no cure

any ideas? experienced similar problem?

Milos
 

·
7777
Joined
·
6,623 Posts
A few thoughts:

Throttle body sync
Inadequate grounds (you need frame, subframe, engine, harness and fuel pump)
Coil sticks input voltage
Coil pickup ohms and fluctuation
Fuel pressure
Intake air or exhaust restrictions

Spray carb cleaner on the pipes when running to see if you have a dead cylinder.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #3
57x - thanks for your thoughts

I have decided to concentrate on fuel pump & inadequate grounds at first because when I have put my bike on a paddock stand, engaged into 1st gear and tried to rev the engine past 4000 rpm - it passed 4000 without any hiccup, no hesitation at all

therefore I have drained the tank and I am going to pull the fuel pump out to see whether there is any blockage
I will also check all circuit grounding points for any corrosion or other fault

let's see what happens next ;-)
 

·
Registered
Joined
·
138 Posts
Discussion Starter #4 (Edited)
I have finally got to the bottom of the fuel pump - filter was incredibly clogged up !!!

I have 2 more questions for you guys:
1) does anybody know what is a INNER DIAMETER of Kawi OEM 2008 - 2010 fuel pump gasket?
2) does anybody know where I can get petrol resistant O-ring gasket in a dimension of 76x84x8 mm?

reason for both questions above is as follows:
when I have adapted my 7R tank to accept 10R'08 fuel pump I did not have OEMfuel pump gasket nor dimensions of it. I have bought of-the-shelf gasket of said dimensions and made flange groove accordingly. As it turned out that gasket was not petrol resistant and I had to use red in-a-tube petrol resistant sealant. I had no petrol leaks; however, I was over enthusiastic with sealant application. Remains of the sealant + not really well flushed out tank after welding resulted in a fuel filter being totally blocked after a year of use.

Just as Maveric in a Top Gun movie used to say "It was stupid!! I know better than that!! " I am now on a hunt for a real seal ;-)
 

·
Registered
Joined
·
138 Posts
Discussion Starter #5
problem solved - clogged fuel filter was the one to blame

I have stripped the pump down, cleaned thoroughly, put it back together and mounted on a tank using new seal - fits perfectly, pulls like train through the revs with no probs so far
 

·
Registered
Joined
·
1 Posts
problem solved - clogged fuel filter was the one to blame

I have stripped the pump down, cleaned thoroughly, put it back together and mounted on a tank using new seal - fits perfectly, pulls like train through the revs with no probs so far
I'm praying this works for my 2010 zx10r...having same issue. Previous owner cut a hole through the bottom of the fuel filter witch what looks as if he added a larger pump that seems to be very restricted. Ordered a new oem pump and keeping my fingers crossed this is the problem
 
1 - 6 of 6 Posts
Top