Kawasaki Ninja ZX Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
ok so i began having problems with my bike jumping out of second gear last week. I took it to the shop where they were going to replace the clutch to see if that would correct. it didn't. I have since determined that its the shift fork and/or gear dogs. that sucks. anyway, while it was in there, i had them check the valves and timing chain. he said they were both good and under specs. but now my bike runs like crap. it sounds different than it ever has and it has no power up to 5k rpms. i've got 16k miles on it and have had conintuous performance out of ever since i originally bought it. the mech says it's nothing that he did. says i need to get a power commander to correct the problem. why would i need to do that? i've never needed one up till now. anybody got any advice to offer? i think he's getting thrown off by an error code from the exhaust servo. i've got a muzzys on there. there was a servo limiter to keep the FI light from coming on, but the servo gave out about 6 months ago and the light came on. no decrease in performance though. thanks in advance for any help.
 

·
Registered
Joined
·
92 Posts
Hows does it idle, like when u blip the throtle, does the rpm come down like it used to, or does it hang a bit. Maybe they messed up on the cam timing, and are off by a tooth? and for the noise could be the cam chain. i doubt it would be the valves becuase shim bucket valves (the ones you have on your bike) tighten over time, where as tappet or screw adjuster valves loosen creating that tap or nock noise. personally i would take it back to the dealer, say you are unhappy with the work they did and ask for them to fix it free of charge, or take your bike somewhere else from now on. Also if you haven't had your throtle bodies sync'd ( like a carb sync) you should get that done as well. Good luck and hopefully you get'er figured out!
 
1 - 2 of 2 Posts
Top