Kawasaki Ninja ZX Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hello again everyone, I've had my 12 for about a week and I'm pretty sure there's a small issue with it. :squint At idle speed it runs like it has a really fat cam in it (rough idle cam). When I rev the engine up to 2-3grand or so, you can really hear and feel a miss. Is this normal? I'm assuming not.

Being this is a new bike here's my checklist of things to look over:

- Check the plugs for gap and abnormal color
- Compression test
- Check the plug wires for OHM readings
If all this checks out: add some SeaFoam to the tank and drive it for a bit; if still idling rough:
- Clean the injectors.

The valves have never been checked for clearance, it's got 12,000 miles on it too. So I'll save that for last.

Am I missing anything here? Thanks for any insight / advice / criticism all

- Ryan
 

·
Registered
Joined
·
117 Posts
Does it run better at higher RPMs or does it just get worse?

If it acts like fuel starvation it could be injectors or fuel pump pressure

If it acts over rich I would check the water temp sensor. It might think the bike is colder than it really is and over enriching it.

BTW what year is it? There is a big difference between a 6 year old bike with 12k miles and a 1 year old bike.
 

·
Registered
Joined
·
117 Posts
Unfortunately no. The manual calls for you to pull off the supply hose located just behind the right side throttle body and use a special T adaptor with a nipple that fits in the hose on one side, a hose that goes on to the injector rail nipple and a threaded connector for the guage.

I would definetly check the plugs first. BTW this bike has individual stick coils that sit on top of the plugs. There are no high voltage plug wires.
 

·
Registered
Joined
·
199 Posts
The 12R will surge at idle, that part is normal, but increase the idle speed to 1300 or so and it should be smooth as a babies butt.
In the summer in stop and go traffic my Y2K12R temp gauge will go to the makrd above dead center, then after moving at a good speed for a while it will drop back down to the center mark.
 

·
Registered
Joined
·
9 Posts
When my TPS went bad it burned an exsessive amount of fuel and a very rough idle... I believe its a 2000 ZX6r TPS is the same,they don't sell the 12 TPS seperate..
 

·
Registered
Joined
·
19 Posts
I just changed my plugs. Yours look rich. Changed to Brisk and it runs much much smoother and my decel popping is 85% gone.
 
1 - 11 of 11 Posts
Top