Kawasaki Ninja ZX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I give it plenty of time to warm up and then take it out. At random spots the bike will just cut out. Not die , but shut off. I have to just do random things to get it back on everytime. Then when it comes back on , it runs just fine and I will take it 40mi+ , with no problems.

So here is what I am thinking: A) the kill switch has a malfunction B) the kickstand safety has a malfunction C) the "lay down" kill switch is malfunctioning( does this bike even have one?)

Thoughts /ideas?

thanks RZ
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Well I took it out Friday , and it did it again, but I think that I have deduced that it is the Kickstand Killswitch (whatever) . I think that the spring is also a little worn and I might just need to replace the entire unit. Where is the best place to order these ? Thanks RZ
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Took off the switch , and it did nothing .....

despite the lack of response here, I am going to keep up with this , in case someone else runs into this problem.

any other ideas are welcomed.
 

·
Registered
Joined
·
990 Posts
Drain carbs to check for water or crud in the float chambers.

Also check fuel filter(s)

If any water or crud present the tank may need flushing out.

Also check the fuel tank is venting properly. If you have a spare key put it in the filler cap & open it when it start to die, if it picks up straight away venting is the culprit.

HTH
 

·
Registered
Joined
·
53 Posts
check your electrics -- test the volt reg/rec, and the alternator output. If it's not charging properly, maybe over time the system is heating up or losing power, and it cuts off when it gets beyond some limit.

Just a thought.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
I am changing the battery first , and then try this .... it didnt look good from the Voltage Meter..... we'll see...
 

·
Registered
Joined
·
10 Posts
what do you mean by "cuts out"? all electrical or it just kills the ignition? sounds like you were on the right track with the side stand switch
 

·
Registered
Joined
·
2 Posts
Solution found? Let me know.

If you found your answer I'd appreciate hearing. I have a very similar problem with my 1985 Ninja. It just cuts out when riding. All lights and electrics are on, I can crank the engine but it won't even cough. Then for no real reason it will start and run again. I've replaced the igniter, and it seemed to happen less frequently, so I thought it might be the igniter connector or wiring harness.
I really want to fix this, or I might just get rid of the bike (I'm the original owner, and it is in pristine stock condition, 13K miles, so I prefer not to.)
Cheers for any help.
 

·
Registered
Joined
·
81 Posts
could be a bad or loose ground to the fuel pump or something. I had the same prob before and that's what I found.
 
1 - 10 of 10 Posts
Top