Kawasaki Ninja ZX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
hey guys. i just purchased a 99ZX7R. been ridin for over a year and i gotta say that i love this machine.

right now i'm having some trouble with what seems to be a fuel cut. i'll ride the bike for about 5miles or 10min and the bike will just die. i'll give it gas, and it wont go. crazy part, is that it will start right up after dying and ride around for a little bit, but the same thing ensues.

i'm mechanically inclined and i'm thinking pump or filter. i've heard that this is a common problem among the ZX7s and i'm wondering if this is true or not. any input would be very helpful. thanks in advance, hope to have some pics up real soon.
 

·
Registered
Joined
·
1,026 Posts
I just got rid of my 00' 7R, and I never ever experienced what you're talking about on my 7 or any other bike I've owned.

My first thought would've been a dirty tank and the grunge working it's way around and plugging off the supply. Something similar to a bingo chip in a car's gas tank. Plugs it off and the motor quits, once the crap settles back down, it's good again, until it works it's way up to plug it off again.

There is definitely a wealth of knowledge on here, and I'm sure someone can steer you in the right direction.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
i've had that problem with my wifes FZR, and it ended up being the pump. i definitely see your point. i've put a little seafoam in the tank to see if that'll do anything, but i'll keep you guys updated until i fix it
 

·
Registered
Joined
·
990 Posts
Put a spare key in the fuel filler cap & when it starts to die open the cap up. If it picks up then it will be vents to the tank that are blocked somehow. Not sure how they are arranged on the 7 but this is an easy prob to isolate.

If the cap trick does not work check fuel filter is not restricting fuel flow & look for debris in the tank.

If the above check out okay then next look at the fuel pump. 1st check that no pipes pinched up anywhere.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
i think i've narrowed it down. tell me what you think.????

when i start it its very hardt to start. the bike will idle fine while on the kickstand. but when i sit on it and stand it straight up, it starts to die slowly. i'm thinking the fuel pump just like on my wife's bike. it did almost the same thing. oh.... by the way, i've found that my starter solenoid is going out. i have to bang or smack it in order for the starter to work. where can i pick up a new solenoid????
 

·
Registered
Joined
·
19 Posts
i would check the vac lines from your carbs to airbox, you need equal pressure or you wont get enough gas , if there missing then that would be the problem
 

·
Registered
Joined
·
9 Posts
yo, when the bike starts, you gotta remember that it is a carburated model, so let it warm up. your problem lies within the fuel pump. take it off the bike, and take off the one screw which holds the top piece on, you will see exactly what im talking about. there should be a little metal piece connected to a spring with a magnet attached. it should be burned down the center....ive seen this problem before with the zx7's. dont know why, it just happens. got spare zx7 parts? give me a call 509-263-6365. Paul
 
1 - 8 of 8 Posts
Top