Kawasaki Ninja ZX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
205 Posts
Discussion Starter #1
Ok, so I rebuilt the clutch master and slave today. There was a lot of trash hiding behind the slave cylinder, bout a quarter teaspoon of dirt, so it needed to be done but it didn't solve my problem. going to pull the clutch cover off again and measure the friction and separator plates separately and see where the hell i went wrong. Anyways i threw on one of the plastics and took some pics with the new powder coat on the wheels. wish i could have afforded re-chrome but i'm really happy with the new look.




 

·
Registered
Joined
·
205 Posts
Discussion Starter #3
The only reason its so clean is cause i can't ride the damn thing. It just sits in the garage, :nana taunting me :nana
 

·
Registered
Joined
·
205 Posts
Discussion Starter #7
they work great. no chatter, no squeal, not to heavy, and they appear well made for what i paid. $199 plus $50 for shipping for all 3 rotors. the seller was racingboy8261 but i think his price has gone up since last year.
 

·
Registered
Joined
·
205 Posts
Discussion Starter #8
i should mention i spend most of my time commuting so if you plan on track days and such i can't vouch for how they would hold up. but for my purposes they work great.
 

·
Registered
Joined
·
1,848 Posts
Looks good!

Definately need to measure those steels and don't be afraid to reuse your old ones as long as they aren't scored or warped.


Josh
 

·
Registered
Joined
·
205 Posts
Discussion Starter #10
thats my plan for this weekend. just waiting for clutch cover gasket.
 

·
Registered
Joined
·
1,761 Posts
looks great man, well at least you solved part of your problem overall, may not be the straw that broke the camels back but your closer. is there any difference between before and after your master and slave cylinder rebuilds? (clutch pull is spoungy, clutch wont disengage, etc?)
 

·
Registered
Joined
·
205 Posts
Discussion Starter #12
The pull feels better, but the release is the same. the clutch doesn't feel like it engage till almost full release and still slips like crazy under hard acceleration. I'm pretty sure its the stack height now.
 
1 - 12 of 12 Posts
Top