Kawasaki Ninja ZX Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have stage two jets in it it caught on fire on me after I put them on because of some of the wiring issues that I had to fix them a small engine mechanic but not a motorcycle mechanic I'm learning I need some help I have a 92 wiring harness on it with a 95 CDI on it it runs a kind of revs up like it should with no load on it and once I put it in gear and try to take off it takes off fine but it doesn't wanting it feels like it's being held back by something I'm pretty sure I have the green and black wire hooked up to the coils properly the green and black wire I have locked out the kickstand switch neutral safety and clutch switch by grounding them out the hot wire comes off of my battery to the cause with a switch my pick up calls are right I don't know what the brown wire does or goes to if anybody can help me I would appreciate it
 

·
Registered
1993 Zx-7 L Model, 2006 ZX-10R
Joined
·
3,798 Posts
I have stage two jets in it it caught on fire on me after I put them on because of some of the wiring issues that I had to fix them a small engine mechanic but not a motorcycle mechanic I'm learning I need some help I have a 92 wiring harness on it with a 95 CDI on it it runs a kind of revs up like it should with no load on it and once I put it in gear and try to take off it takes off fine but it doesn't wanting it feels like it's being held back by something I'm pretty sure I have the green and black wire hooked up to the coils properly the green and black wire I have locked out the kickstand switch neutral safety and clutch switch by grounding them out the hot wire comes off of my battery to the cause with a switch my pick up calls are right I don't know what the brown wire does or goes to if anybody can help me I would appreciate it
I have stage two jets in it.
It caught on fire after I put them on because of some of the wiring issues that I had to fix.
I'm a small engine mechanic but not a motorcycle mechanic. I'm learning and I need some help. I have a 92 wiring harness with a 95 CDI. It runs poorly. It kind of revs up like it should with no load on it.
Once in gear, it takes off fine. But, it feels like it's being held back by something. I'm pretty sure I have the green and black wire hooked up to the coils properly. I have locked out the kickstand switch, neutral safety, and clutch switch by grounding them out. My pick up coils are right. I don't know what the brown wire does or goes to. If anybody can help me I would appreciate it.

Edit: This is the best I can do to make sense of your post. Your brain is going a thousand miles a second. Your first step is to obtain a wiring diagram for both the 92 and the 95. Unless they are identical, then you only need one. Since you have the 92 harness, I would obtain and keep that one.

My 93 zx7 also has a brown wire. IIRC, I accidentally grounded/shorted that wire out on the top of my valve cover and shorted something else out in the process. I ended up replacing the harness altogether. I believe the brown wire goes to the ignition switch. If you follow it, it'll show you where it comes from and where it goes to.

2. Your bike is running poorly because it is probably not tuned properly. If you're running a stg.2 DJ kit, your carbs should have been cleaned and synced; the air filter replaced with either a new stock filter or an aftermarket performance filter; and you should be running an aftermarket full exhaust system.
 
1 - 2 of 2 Posts
Top