Kawasaki Ninja ZX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
First off let me say, hello. I am new to this forum and new to the Kawi lifestyle. 8 days ago I purchased a '06 ZX-10 in "Pearl Solar Yellow" color (I'll call it orange). So I was out riding it yesteday and at 82 miles on the odo, the bike just shut off. I was at a red light and the bike just plain died. I pulled into the gas station and tried to re-fire with no luck. After a little bit of time I tried again and still nothing. At this point I could notice that the fuel pump was not kicking in. I put the bike in the shop this morning and am awaiting a word from them tomorrow. Has anybody else seen or heard of this happening on another Kawi, or just any other bike for that matter? I already have a bad taste in my mouth with this new bike. Did I just get unlucky or what? Maybe I should just stay with my other bikes. Somebody respond and just tell me this was some freak mechancial failure?
 

·
Registered
Joined
·
14 Posts
Me Too!

Just got my 06 '10R Thursday ive got about 160 on it now. It's awesome :thefinger

rode some this morning and am dying to get back on the road but had to do some work first :rant

BC
 

·
Registered
Joined
·
14 Posts
There is a kickstand switch, an "in gear" switch and of course the handlebar switch any of which could potientially cause that problem. Not to mention wiring to the fuel pump.
 

·
Registered
Joined
·
20 Posts
I had to have my sidestand switch replaced. Had a short or something in it. Would cause my bike to shut off for a second while I was riding it. No problems since it was replaced.
 

·
Registered
Joined
·
14 Posts
Hmmm.....

I might be thinking about either bypassing that or buying an extra just to not have to wait on the shop to fix it.

Those things have a reputation of failing.

:headscratch
 
1 - 6 of 6 Posts
Top