Kawasaki Ninja ZX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Got my engine rebuilt (98 zx9r was running way to rich and it was taking forever to get it started even warm one month later totally lost my power band gos straight through all rpm's without every hitting a power band had spark plugs changed and the shop checked the carbs and said they were good to go (if they actually did is a mystery) Does anyone have any hints or suggestions for this because after 2000 plus in six months im going crazy and the shop that has been working on it said they do not know and dont want to mess with it.
 

·
Registered
Joined
·
201 Posts
here is a website that is devoted to the ZX-9R. There is one guy that knows just about everything about the 9R imaginable. Just post up the question and he should be able to point you in the right direction in what to look for.
zx-9r.net
Good Luck:crazyloco
 

·
Registered
Joined
·
53 Posts
Got my engine rebuilt (98 zx9r was running way to rich and it was taking forever to get it started even warm one month later totally lost my power band gos straight through all rpm's without every hitting a power band had spark plugs changed and the shop checked the carbs and said they were good to go (if they actually did is a mystery) Does anyone have any hints or suggestions for this because after 2000 plus in six months im going crazy and the shop that has been working on it said they do not know and dont want to mess with it.
hmmm. Interesting.

Has it always done this since the rebuild? And what do the plugs look like? CR9EKs?

For starters, I'd take it to a different shop, one w/a racing background and a dyno. It sounds fuelling-related, but I'm no mechanic.

I agree, I'd be bummed if in the same situation...
 
1 - 3 of 3 Posts
Top