Kawasaki Ninja ZX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
i have a power drop kinda thing somewhere around 10-12 rpm.. its as if the bikes a lil hesitant and in a sec it shoots up.. have a feelin this is got to do with the air and fuel mixture not too sure though :headscratch

my mechanic told me to replace the map sensor? do u think that wud solve the prob?:rolleyes m also changin the air filter.

please advice!! :banghead

Thanks!
 

·
Registered
Joined
·
990 Posts
Without any other info, if the air filter needs changing (or cleaning) it sounds like you need to give the bike a service. Make sure valve clearances & injector (assume it's a late bike from avatar) synchronisation is done.

Make sure service stuff is up to date first then see how it goes before you start looking for other fixes.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #3 ·
Without any other info, if the air filter needs changing (or cleaning) it sounds like you need to give the bike a service. Make sure valve clearances & injector (assume it's a late bike from avatar) synchronisation is done.

Make sure service stuff is up to date first then see how it goes before you start looking for other fixes.
sorry abt that.. my bad!

well :

1) The bike's in Stock condition without any mods whatsoever..although i have disconnected the SeRVO as i messed it up...

2) my bike's done just abt 9000 miles.. and its an 05 636

3) well, it was perfect when i bought the bike... only after a few services and after disconnectin the SERVO i have faced this problem... although i think the SERVO wudnt make much

4) also, i experience the power drop only when i have a constant grip on the throttle and have a steady increase in power band...

hope that info helps..

Thanks again!
 

·
Registered
Joined
·
990 Posts
I assume by servo you mean for the exhaust system. I don't know specifics for the 6R but if it has a valve in the exhaust this is there to control the exhaust flow/back pressure. If the motor is stuck fully open it will reduce back pressure, which at low to mid revs which will cause some sort of a hole/dip in the powerband. If the valve is at the other extreme it will stifle the power at top revs.

Fix this & it will probably go back to how it should be.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #5 ·
I assume by servo you mean for the exhaust system. I don't know specifics for the 6R but if it has a valve in the exhaust this is there to control the exhaust flow/back pressure. If the motor is stuck fully open it will reduce back pressure, which at low to mid revs which will cause some sort of a hole/dip in the powerband. If the valve is at the other extreme it will stifle the power at top revs.

Fix this & it will probably go back to how it should be.
yep its the butterfly actuator A.K.A servo for the exhaust... do u think i might be able to solve this issue if i change the servo?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #7 ·
Yep, very good chance.....

Look at the valve, you'll probably find it's fully open.

The thing is there for a good reason, if it's not working it will mess up the power delivery as stated above.

Thanks.. m gonna get a new servo right away.. will keep u posted ..
 
1 - 7 of 7 Posts
Top