Kawasaki Ninja ZX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I'm a new guy on the block needing some assistance. My left turn signal stop work a few days ago nor the hazard lights. The right turn signal works fine but blinks really quick. Can anyone point me in the right direction? Bulbs are still good. HELP.. I'm due for inspection soon, beside i like letting drivers know when I'm going to make a left!
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I'll check the bulbs again and let you know. I haven't fitted anything new. I would like to get the intergrated LED set for my bike but haven't made the deicions yet. I'll let you know what happens.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
No dice... Both bulbs are still good. Looks like it might be a short somewhere. I also noticed that my hazards don't work either. I also noticed that when I would turn on the left turn signal the lights dim a bit and come back. When i turn on the hazards i see the same thing happen. How would I be able to trace the short? Does anyone have a schematic so I can see what actually is involved with the turn signals?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
I got a 2002 ZX9R. I finally stripped her down and found the short. I guess who had the bike before me didn't solder the wires correctly. I found the wire touching and grounding the wire. After i soldered it back it worked fine. Thanks for the help.
 
1 - 6 of 6 Posts
Top