Kawasaki Ninja ZX Forum banner
1 - 8 of 8 Posts

·
Registered
1992 ZX-7(J) 2017 Z650
Joined
·
57 Posts
Discussion Starter · #1 ·
Trying to install an integrated tail light into my 92 J. It came with two giant resistors labeled 20W 5Ω J.

The turn signals just stay on, as if there were no resistors in place.

Can I just swap out the flasher relay? If so, does anybody know what would work on this machine?
 

·
Registered
1992 ZX-7(J) 2017 Z650
Joined
·
57 Posts
Discussion Starter · #3 · (Edited)
Oops, nevermind scratch that, ignore above post. That was a hazard flasher, so now both my turn signals flash at the same time 😐

It's a clue though, if I can find a similar flasher relay, it should work.

EDIT: It says hazard or turn signals. So I'm now I'm confused.

EDIT EDIT: It works fine. Long story, but it works without resistors.
 

·
Registered
1992 ZX-7(J) 2017 Z650
Joined
·
57 Posts
Discussion Starter · #6 ·
Thanks Honda434 😊

It's pretty rough tbh, first time painting anything and I didn't get all the flaws out of the fiberglass. I actually cracked the glass being careless so I learned how to patch that and dremel-fix gel coat. It's been fun.

Here it is with the lights off:
Tire Wheel Automotive tire Vehicle Automotive lighting
 

·
Registered
Joined
·
79 Posts
Thanks Honda434 😊

It's pretty rough tbh, first time painting anything and I didn't get all the flaws out of the fiberglass. I actually cracked the glass being careless so I learned how to patch that and dremel-fix gel coat. It's been fun.

Here it is with the lights off:
View attachment 22075
I think I have the same one on my 2003... The tail light works great but I can't get the signals to work.
Did yours come with just two wires??? Blue and Yellow?

Todd
 
1 - 8 of 8 Posts
Top