Kawasaki Ninja ZX Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey everyone I just bought an 07 zx6r in good condition but there is an issue and I’m new to bikes so I could use some help. While riding the bike runs fine however it stalls randomly when coming to a stop for example, at a light going into neutral and stopping, the bike would turn off. The only way to turn it back on would be turn off the key and let it sit for a little while maybe 10 minutes or so, sometimes longer. This issue also occurred once when revving the engine a little in neutral. Then the FI light would start flashing after trying to turn the bike on again. After finding the FI code I got code 12 which I believe is an inlet pressure sensor malfunction. I plan on taking the tank off and inspecting it. I searched but didn't see much discussion on FI 12 code, just how to test but no discussion about symptoms.
 

· Registered
Joined
·
396 Posts
I'll start by saying I'm not a zx6 person, but by reading what you have described I would say it could be an air leak in the pipe work from the throttle bodies to the pressure sensor, this would give you random stalling and probably the pressure sensor fault code.
If it was just a faulty sensor the F1 light I would expect to come on straight away. If it is the sensor, and if the zx6 is like the zx12 you could swap it for the static air pressure sensor, but where that is on your bike I don't know, on the zx12 its at the back of the bike under the tail fairing righthand side.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
This looks like a good writeup

I saw that and I'll end up testing the sensor but I think for him it ended up being something else. But definitely useful information, thanks
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I'll start by saying I'm not a zx6 person, but by reading what you have described I would say it could be an air leak in the pipe work from the throttle bodies to the pressure sensor, this would give you random stalling and probably the pressure sensor fault code.
If it was just a faulty sensor the F1 light I would expect to come on straight away. If it is the sensor, and if the zx6 is like the zx12 you could swap it for the static air pressure sensor, but where that is on your bike I don't know, on the zx12 its at the back of the bike under the tail fairing righthand side.
That's what I'm thinking because thr fi 12 code doesn't appear right away, only after trying to start it later. When it shuts off there's no code most of the time. Do kawasaki usually throw code if the fuel pump doesn't pump? I can hear it priming and some other weird clicking notice from near rhe seat. I'm going to remove the seat and gas tank to inspect
 

· Registered
Joined
·
396 Posts
If it's like my zx12 B4 when I switch the ignition on I can hear the pump prim with a whirrr, and the injectors test with a tat tat tat tat, hard to describe the sound but you'll know what I mean when you hear it as it sounds like what you are describing. :)
As for the fault code, I can't remember off hand, I'll look it up........ no I can't find anything but that's not to say there isn't one.
 
1 - 6 of 6 Posts
Top