Kawasaki Ninja ZX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
new guy here....just got my first bike 07 zx6r picked it up from the dealership and he started it before i left but when he started it and reved it up a little and it would hang around 2300 then drop back down. i tell the dealer and he said its due to the new exhaust (two brothers) and that the map should ajust to it ...but i've look around on here and some people say its a air leak or a atmospheric pressure line not connected? any input would be great thanks
 

·
Registered
Joined
·
240 Posts
First thing i would check would be a hanging throttle cable. After reving it up, try twisting the throttle towards the front of the bike. If this causes it to quickly return to idle, you may just need to lube the cables. If this is the case and lube doesnt work, your cable may be frayed inside the plastic housing causing it to hang, thus requiring new cables. Always try the simple things first.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
just lubed and no change but found something the dealership missed when they listed it they said it had a two brothers exhaust and elit kit but i just found a power commander 3 under the seat could the pc3 cause this problem or did the person that installed it have missed plugging back in the lines?
 

·
Banned
Joined
·
3,608 Posts
Yes it could. If it's not mapped right, or something isn't connected right that would cause all sorts of issues. I would take it out and go back to stock to see what happens.
 

·
Registered
Joined
·
3,145 Posts
just lubed and no change but found something the dealership missed when they listed it they said it had a two brothers exhaust and elit kit but i just found a power commander 3 under the seat could the pc3 cause this problem or did the person that installed it have missed plugging back in the lines?
yummy, pc3!:mfclap +1 for christikitty
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
ok so brought the bike down today to the dealership and heres the story. When i bought the the bike the sales rep. started it and cracked the throttle and the rpms were hanging and i asked what the problem was and he said its just the pipe and that it needs to be worked in. When i dropped it off the owner helped unload the bike and said this bike has been a ongoing problem because the other two owners had the same problem with it and they dont know what it is. Now the way i see the sales rep lied to me and never throught of telling me that the bike has had this problem. Called them later on and now they cant even keep the bike running. I'm pretty pissed off because when i spend 7000 on a bike i expect it to run. I've only put 64 miles on it. Question is does lemon law apply to motorcycles? oh and when i called they said the bike seems to be only running on 3 cylinders.
 

·
Registered
Joined
·
47 Posts
ok so brought the bike down today to the dealership and heres the story. When i bought the the bike the sales rep. started it and cracked the throttle and the rpms were hanging and i asked what the problem was and he said its just the pipe and that it needs to be worked in. When i dropped it off the owner helped unload the bike and said this bike has been a ongoing problem because the other two owners had the same problem with it and they dont know what it is. Now the way i see the sales rep lied to me and never throught of telling me that the bike has had this problem. Called them later on and now they cant even keep the bike running. I'm pretty pissed off because when i spend 7000 on a bike i expect it to run. I've only put 64 miles on it. Question is does lemon law apply to motorcycles? oh and when i called they said the bike seems to be only running on 3 cylinders.
So shitty...

What ended up happening?
 
1 - 10 of 10 Posts
Top