Kawasaki Ninja ZX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
548 Posts
Discussion Starter · #1 ·
For some reason, out of no where today, my fuel pump stays on and the kill switch doesn't work.:eek:hno Has anyone had these problems or just know what it can be? I also found out that my throttle cable is bent like crazy so the throttle sticks a bit. Between that and no kill switch, there's no way I can ride this thing and feel safe. :runaway Downfall is I still have to drive this thing home tonight when I get off from work. Everything was fine earlier today when I left home. I left work to run a few errands and noticed the kill switch not cutting the bike off and once I turned the key to kill it, the fuel pump stayed on and just continuously runs so I had to pull the main plug to cut it off until I get ready to leave to go home tonight. Please tell me it's a fuse or something simple.
 

·
7777
Joined
·
6,877 Posts
I had a similar issue when I had the alternator wired backwards. Did you have to splice that yourself? The visual thing on those wires is to hook the orange wire to the red wire; then hook the black wire to the white. That is actually backwards, and what I did stupidly. My connector was fried so I had to connect myself.
 

·
Registered
Joined
·
548 Posts
Discussion Starter · #3 ·
No, I didn't do anything with the alternator. I bought the bike as is and its ran fine for the last 250 miles or so and this was all of a sudden that these problems popped up. I'm gonna check the fuel pump relay and hopefully that's the issue with that since I'm ordering another relay just in case to have on hand. I'm also gonna open up the kill switch and check everything in there to make sure all the solder joints are good. Beyond that, I don't know what else to try.
 
1 - 3 of 3 Posts
Top