Kawasaki Ninja ZX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
After the bike warms up I notice a pronounced stumble at low speeds. I brought the bike for service where they replaced the plugs, adjusted the valves, replaced the air cleaner. A day later the bike exhibited the beginnings of the same problem after a long ride and I'm afraid it's coming back.
When idling the rpms will go up and down some but when riding the engine will stumble until well revved up.
Any ideas out there of what the problem/solution is? Thanks for any help.

zxhank
 

·
Quinton Phuckin Tarantino
Joined
·
18,914 Posts
Synchronize the throttle bodies
 

·
Registered
Joined
·
1,466 Posts
I
 

·
Registered
Joined
·
1,466 Posts
I had a similar issue not too long ago, my engine would hesitate around 3k Roms and the dealer could not figure it out for a couple of weeks. Then one day I was in the garage with a beer and thought hmmm I should ohm my coils and sure enough it was a bad coil. So grab yourself a beer coors light, corona, whatever you prefer and ohm your coils. If that isn't the prob well atleast ya have a good time anyway. Nah just joking but one of mine did fail it was about .3 under the range and there it was.
 

·
Registered
Joined
·
9,979 Posts
+1 ^^^ those.

It seems the typical m.o. can be tracked back to something done recently to the bike: fuel additive of improper measure, something not reattached after maintenance work, parked under a roof drain spout and drowned, etc... Start with the obvious and work your way up to the obscure.
 
1 - 6 of 6 Posts
Top