Kawasaki Ninja ZX Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
ok so when i try to start the bike, it wont crank it just clicks (from the solenoi/relay) i charged the batt and it cranks once or twice then it stops, i removed the starter and tested for faulty connections, and it works fine, the relay does click and it does give me a + signal on the side that goes to the starter, so im buying a new batt and hope that is it.

also the bike had the neutral switch blown out, it doesnt sense when its in neutral, the click problem started before i blew the neutral safety switch, so now i have to press the clutch every time, do you guys think that any of those safety sensors would make the bike no crank, but dont forget that IT DOES CLICK which mean that the relay is gettin power...

also sometimes when the bike is sitting i test for groung on the starter cable the one that comes from the realy and it DOES NOT give me any signal, neither + or -

HELP.!!!!!!!!
 

·
Registered
Joined
·
201 Posts
looked at my service manual for any suggestions and here is what they came up with.
1. engine kill switch off
2. fuse blown-check main fuse and starter circuit fuse
3. battery voltage low
4. starter motor defective
5. starter relay defective
6. starter switch not contacting- check for wet,dirty,corroded terminals- take switch apart and clean
7. wiring short or open circuit-check wiring harnesses for lose or frayed wires
8. Ignition or main switch defective
9. engine kill switch defective
10. faulty neutral, side stand, or clutch switch- test and replace as needed
hope this helps and good luck
 
1 - 2 of 2 Posts
Top