Kawasaki Ninja ZX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi everyone!

I bought a used 95 zx7 at the begining of the summer, everything was running fine but yesterday my engine started knocking and became pretty loud after a couple of minute riding in the city (slow riding, nothing hard).

I came right back home, I didn't want to blow my engine on the highway. I made a video if some of you want to listen to the engine:
http://www.youtube.com/watch?v=oW6VHpqmWjY&feature=youtu.be

I took out the tensioner, it was 6 teeth out (is it the maximum lenght? I could'n force it to click one more time) thinking that maybe the CCT is too loose.

I also opened the valve cover and checked the timing, the two mark we're lined up.

I checked the valve clearance, it was not perfect but everything was within spec.

I changed the oil, nothing suspicious was in the old oil.

Is my engine dying..?! I'm thinking of buying the APE manual CCT, but I'm not sure that it's the solution...! Any clue?

Thanks!

Fred
 

·
Registered
Joined
·
188 Posts
Since you already checked your cam tensioner and your valve lash, id check your exhaust bolts to make sure your header is tight...(had that happen once, kinda sounds like a bad tick if loose..or blown exhaust seal), and then if they are good, check your oil for bearing material. That would be my suggestion, im sure some of the guru's here will have more info then I here soon.. :)
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Update,

The oil pressure is good too. With a soapy water i coudn't find any leak at the exhaust header.

I took off again the tensioner with a mecanics friend, the ratchet was locked in place, not allowing the rod to take a step out. With a knock well placed, we could get it to work properly, resetted it and plug it in back in.
The engine noise changed a little bit, but nothing too impressive, we got it out again and it was jammed again at a different place.
I think the APE tensioner will be the next step. A 50 buck guess that cost less than getting the engine out and open at the garage...!

I think a compression test will be necessary if it's not the tensioner, maybe I have a bent valve?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
Hey guys, I found a crack in my exhaust manifold near one of the bolt. I think I need a new exhaust manifold..! Is there any way to repair it?

If it was a rod knock or a valve, the sound would also be present when the starter run right before the engine starts, right? My engine is knocking only when it's started, so I think the noise comes from the exhaust leak.

It's my first bike, so excuse me if I ask stupid questions!

Thanks!
 
1 - 5 of 5 Posts
Top