Kawasaki Ninja ZX Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Some help if anyone can on my j2 yesterday had a 250 round trip with a few stop offs not to far from home when the bike cuts out as if run out of fuel
Now if I put the choke on it will start as soon as I take it off it cuts out again
Once left to cool down after a few hours it runs fine again ?
Can anyone help on this will be great
 

·
Registered
Joined
·
188 Posts
What RPM does it start cutting out at?
Does it idle without the choke on while warm?
Did the bike sit for any period of time?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
I went on a 20 min ride this morning all ok but don't wont to go to far because it will do it again
And no warning it just cuts out like you've run out of fuel. Thanks for the replays
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
What RPM does it start cutting out at?
Does it idle without the choke on while warm?
Did the bike sit for any period of time?
No the bike only sat for a couple of weeks and won't idle at worm has to have choke
 

·
Banned
Joined
·
3,608 Posts
Clean the carbs, and you may have a failing fuel pump or fuel pump relay
 

·
Registered
Joined
·
188 Posts
Clean the carbs, and you may have a failing fuel pump or fuel pump relay
+1
Start with cleaning them out. Make sure everything is super clean. And your floats are correct... dont read your gauge wrong and set them at 10mm either like my dumbass did once...lol!!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Thanks will give the carbs a clean and set up mid week when I'm off work thanks
 

·
Registered
Joined
·
488 Posts
I have had the same thing happen to me a couple times before... My J1 cuts out when I leave a stop or traffic light when the temperature gauge is up halfway (so a lot of city riding or stop-and-go traffic). It will cut out for a quick second when I take off. One time I wanted to put my stock muffler back in because I was going for an evening ride and didn't want to annoy anyone in residential while coming and going at 10pm. Well the problem was worse with the stock muffler (of course my jetting was "adjusted" when I put in my aftermarket can last year).

So that led me to believe that part of the jetting is to blame. I never bothered to investigate further because I put my aftermarket muffler back in the next morning, but my guess is that the culprit is either pilot screw or float level (my money would be on the latter being too lean). My fuel pump contacts are brand new and the relay checked out ok. Just giving you something to think about.

It doesn't happen very much because I'm rarely stuck in traffic.
 

·
Registered
Joined
·
259 Posts
I don't disagree with any of the above, but wanted to add; check/replace fuel filter as well. And make sure fuel lines are insulated from heat properly.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #13

·
Registered
Joined
·
1,761 Posts
sounds like your having the same problem im having, vapor locking in traffic and when i stop and the motor heats up my fuel system making me wait a good half hour. the problem now days is with the fuel, there is too much ethanol in fuel causing it to be too volatile. i just started an experiment with the fuel treatment "star tron enzyme fuel treatment" to make it less volatile and will hopefully cure our vapor locking issue.
 

·
Registered
Joined
·
1 Posts
Some help if anyone can on my j2 yesterday had a 250 round trip with a few stop offs not to far from home when the bike cuts out as if run out of fuel
Now if I put the choke on it will start as soon as I take it off it cuts out again
Once left to cool down after a few hours it runs fine again ?
Can anyone help on this will be great
Did you manage to find the problem? We are having the same issues and have done and checked everything that has been discussed on here but the same happened again today, except for not starting after waiting 2 hours for her to cool down.
 

·
Registered
Joined
·
241 Posts
Did you manage to find the problem? We are having the same issues and have done and checked everything that has been discussed on here but the same happened again today, except for not starting after waiting 2 hours for her to cool down.
That post was 2013 so might be worth starting your own with Details of your Bike:- Age , Mileage, Any work carried out recently etc, More details the better.
 

·
Registered
Joined
·
3,168 Posts
Did you manage to find the problem? We are having the same issues and have done and checked everything that has been discussed on here but the same happened again today, except for not starting after waiting 2 hours for her to cool down.
Sounds like no fuel or no spark.

That post was 2013 so might be worth starting your own with Details of your Bike:- Age , Mileage, Any work carried out recently etc, More details the better.
+1
 
1 - 17 of 17 Posts
Top