Kawasaki Ninja ZX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Seeing something on the ol' girl last night and I had to turn on the key and when I did i noticed the FI light came on very briefly and also after the speedo has cycled through the oil light stays on, not riding tho. Should I be concerned?


Also my HID's have been flickering and being weird and as i was turning the bars to see if they flickered at a certain point the F.I seemed like it cycled again (this was probably after a full minute of the key being on) but not like when u turn the key for the first time. Any concerns or answers???


Thanks! Oh and PS if anyone has an HID kit for cheap let me know mine was routed wrong and stressed the low beam connection showing some wear on it maybe shorting out. It will work perfect if its plugged in perfectly right but some movements it dosnt like. Let me know!!!!!
 

·
Registered
Joined
·
147 Posts
The oil light and FI light will stay on when the key is on and the engine is not running.
This is because you don't have any oil pressure and your FI system is not firing... because the engine is off.

As far as the HIDs, i would recommend replacing the damaged wiring and soldering everything instead of crimping it.
 

·
Registered
Joined
·
602 Posts
The oil light and FI light will stay on when the key is on and the engine is not running.
This is because you don't have any oil pressure and your FI system is not firing... because the engine is off.

As far as the HIDs, i would recommend replacing the damaged wiring and soldering everything instead of crimping it.
+1, never crimp, always solder, then shrink wrap
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #5 ·
I fixxed the HIDs theyre done right now, the one who had it before me ****** rigged the shit out of them...


on the flipside this thread wasnt really for the HID's hahahaha
 

·
Registered
Joined
·
519 Posts
Check the past fi codes by going into dealer mode 2.
 

·
Registered
Joined
·
18 Posts
Check the past fi codes by going into dealer mode 2.
+1 if the FI light stays on

on my 04' the oil light stays on until you start it up but the FI light should only come on when you first turn the ignition and then go off again
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #8 ·
+1 if the FI light stays on

on my 04' the oil light stays on until you start it up but the FI light should only come on when you first turn the ignition and then go off again

TRUE TRUE! +1 on that note lol

But also when i turned the key i discovered two weird noises, one sounds like s suction noise coming from the take when i turn the key on, and another noise right after i turn the key it a quick ticking/triggering sound. hard to explain, does it for about a second or two until the speedo cycles.... any answers??? hmmmmm
 

·
Registered
Joined
·
147 Posts
The sucking sound from your gas tank is just that, a sucking sound from your gas tank. It's priming the fuel system. The ticking sound is your exhaust servo running it's pre-flight check.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #10 ·
The sucking sound from your gas tank is just that, a sucking sound from your gas tank. It's priming the fuel system. The ticking sound is your exhaust servo running it's pre-flight check.
Can always count on this place for some extra worries i have!!! thanks guys!!!
 
1 - 10 of 10 Posts
Top