Kawasaki Ninja ZX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
649 Posts
Discussion Starter · #1 ·
Has anyone changed out their stock clip-ons? If so what type did you put on and why????? I recently low sided at about 20 mph and all is fine (LSL Slider did it's job) but the right bar seems a little bit tweaked. I took all the controls off and looked at it (looks straight) but I couldn't get the mounting allen bolt loose to take it off. It feels like a gorilla tightened it down. Also the metric allen wrench doesn't seem to fit tightly enough to really crank on it, it wiggles just enought to feel like it could strip the bolt. Any help or suggestions would be appreciated. :smile
 

·
Registered
Joined
·
449 Posts
Has anyone changed out their stock clip-ons? If so what type did you put on and why????? I recently low sided at about 20 mph and all is fine (LSL Slider did it's job) but the right bar seems a little bit tweaked. I took all the controls off and looked at it (looks straight) but I couldn't get the mounting allen bolt loose to take it off. It feels like a gorilla tightened it down. Also the metric allen wrench doesn't seem to fit tightly enough to really crank on it, it wiggles just enought to feel like it could strip the bolt. Any help or suggestions would be appreciated. :smile
Hey Mijo, Do not ever monkey with kranky nuts/bolts: ALWAYS heat them up first. Nothin like breakin the heads off of bolts with the stud still there(I have done this many times), go to Wally world and pick up a torch and stryker (prolly bout $13,$14) and just put some heat on your kranky bolts and then put a wrench on it. You will be golden bro~
 
1 - 5 of 5 Posts
Top