Kawasaki Ninja ZX Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I need help I have 2003 zx9r with 33k miles was running good until it sat outside i for a couple days. Then bike wouldn’t go over 30 mph or 3k rpms in any gear. I have changed fuel filter, air filter, spark plugs, I have put injector cleaner in with a new gas also I have cleaned the carbs out 3 times and still nothing. Please help me I really need my bike to run.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #2
Also don’t know if this matters but weather at night was around 40-45 degrees and it rained a couple of days. Also turns over good idles fine I could freely rev the bike when I’m neutral but when I pull the throttle it will die.
 

·
Registered
Joined
·
112 Posts
After I took my bike apart, I forgot to reattach these pieces and had pretty close to the same results. Reattached the ram air tube and was off..,..
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Checked both sides were connected and now if I rev in neutral it will only go up to 5k rpms. If I full throttle dies down
 

·
Registered
Joined
·
224 Posts
Fueling problem then. Turn the fuel tap to OFF and let the bike run if things start to improve as the fuel runs out then its an over-fueling problem with the carbs.
Time to take the airbox lid off and look down the carbs while the bike is running and fuel tap back on, and see which carbs have a lot of fuel coming up around the main needle.
There are a couple of good zx9 videos on this on Youtube showing this problem. Here is just one of a few.

Normally this means float valves, float heights, float valve seat sealing washers, floats filling with fuel, could also be carb tops not seated properly and not letting the carb slides lift with the vacuum.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
I did as you said let the bike run on off and it just turned off didn’t run better. I haven’t taken the air box off to check should I still do that? Also will this issue be caused by the rain corroding the grounds I’m going to tear it all apart tomorrow to check all the wires. One more thing how many turns for the air/fuel mixture screw and if it’s too much turned out will it cause this issue? I have mine turned out at 2 turns.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
Turned back mixture screws back to 1.5 turns and checked the carbs if it was doing the gas thing and no all we’re running good. One of my slides was closing too fast got that fixed now they all fall back down the same. When you give it throttle are the slides suppose to move or no? Because none of them moved for me.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
Also could it be the rectifier? Battery is less than 2 months old but when I press the brake lever the dash lights dim until I let it go
 

·
Registered
Joined
·
224 Posts
Gently lift the carb slides in pairs to the top and release, they should close with a steady shoooosh, slow ish to close is good. Compare all 4. If they close straight away the carb tops are not seated correctly and so there is no vacuum under the carb tops.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #15
I gently lifted and compared all of them they all came back down with a whooshing noise and at the same time. They all came back slow not fast so the vacuum is good there, but when I rev it the slides don’t move at all. What can cause that should I open the carbs up again?
 

·
Registered
Joined
·
77 Posts
It is pretty hard sometimes to get the slides to seat perfectly.
If they dont.the slides wont lift.
When they are right, you shold feel some recistance when you push the up rapidly, and they should fall down slowly.
You can hear it when you get it right.
Put your fingers on the cover before you put the bolts in, and push THE slides up rapidly and you should feel and hear it when it is right.


Skickat från min moto g(7) via Tapatalk
 

·
Registered
Joined
·
77 Posts
Diaphragm is the correct english word i was looking for.
The rubber thing on the slides.
Membran is the Swedish word F.Y.I


Skickat från min moto g(7) via Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #19
The bike only lets me rev it up to around 4.5-5 rpms will the slides move around those rpms? Also I’ll take the carbs out again so I could check the slides again to seat them properly but I thought I seated them properly because they all slide down the same as well as go up with resistance.
 

·
Registered
Joined
·
224 Posts
I remember when I was working on mine and I managed to kink a spring, what got me was when I rev'd the bike the slides would still lift but when I rev'd it hard that's when I noticed one of the slides stopped lifting after about 1cm.
I know this will not be your problem but its something to be aware of that can happen.

Have you done any valve clearances? just wondering if the timing was set right.
 
1 - 20 of 33 Posts
Top