Kawasaki Ninja ZX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys...doing some research and need any ideas you guys can give!!! :headscratch
Hit rev limiter a few years ago which started a vibration at 4500. Front wheel weight was missing so I got tire rebalanced and this was not the problem..Vibration occurs at 4500 while in neutral at stand still and while in gear going down the road. Had valves adjusted and spark plugs changed, still not solved. Checked motor mounts, bolts, removed center stand. Maybe an internal problem?? Would like to get fixed since it is such a great bike tired of spending $$ and not finding any solutions. THANKS...Bad Kitty
 

·
Registered
Joined
·
990 Posts
Check to see if the exhaust system is touching the frame anywhere, especially If you have an aftermarket exhaust.

Have you done a compression test to check if the valves are okay? A bent valve would show up as a low reading.
 

·
Registered
Joined
·
9 Posts
Hi Bad kitty,

Have you readjusted your balancer? It's located on the right hand side of the engine at the front lowest point of the crankcase. If you have a manual look up the procedure for adjustment, if not I can type out instructions from my manual. Also, have the carbs been balanced recently.
 

·
Registered
Joined
·
18 Posts
I agree that adjusting the balancer is a good start, it's easy to do, the hardest part is pulling off the plastic to get to it is all. And, it doesn't hurt to do it at normal maintenance intervals either. Just don't let go of the slotted shaft while the engine is running, you'll see what I mean when you read the procedure.
 
1 - 6 of 6 Posts
Top