Kawasaki Ninja ZX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
So I had been having problems with my headlight. Wouldn't come on when key switched to the "on" position... and when it would come on out of nowhere, my battery would be dead within a day of riding. So I figured the generator wasn't doing its job. Took the side cover off and turns out, the magnets on the flywheel flew off and there were chunks of magnetic pieces all up in it. With very slight minimal damage to the stator. Replaced the flywheel. Headlight still wouldn't come on and battery would still only last a day. So I replaced the "junction box", "voltage regulator", AND "reserve lighting switch". Now headlight comes on and shuts off when its supposed to. Yay! :D HOWEVER, BRAND NEW BATTERY CONTINUES TO DIE AFTER A FULL OVERNIGHT SUPER SLOW 2AMP CHARGE!!! JUST ORDERED A NEW "stator". Should get it in about a week. Once I replace the stator, if this doesn't solve my problem, anyone got any ideas as to why the bike is draining power from my battery instead of keeping a charge!!??
 

·
Premium Member
Joined
·
11,231 Posts
No idea about the drain, but did you upgrade to the 2nd gen flywheel?

The first gens like to... explode like yours did. Very common problem. You can google the swap.

And are you sure its a drain rather than just not charging?
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
FINALLY!!! A REPLY!!! Didn't think anyone was gonna respond! Knew I could count on you though masta squidge! :) but yeah I got the after market flywheel, it doesn't have individual magnets "glued" on... its like one whole solid magnet strip... but one of the magnets on the STATOR was broke in half but still intact and firmly attached... so I didn't replace it... yet... put bike back together and started riding it with a freshly charged battery... bike worked great for about 2 days and then DEAD BATTERY! So I assume the generator's not keeping the battery charged and the headlight sucks it dry... if replacing the stator doesn't work, I have no clue where to go from there -_-
 

·
Premium Member
Joined
·
11,231 Posts
Not only the headlight, but the spark too. Fix that stator. Get a manual too, tells you how to diagnose all that stuff.

And aftermarket? Best swap is the 2nd gen, not aftermarket.
 
1 - 4 of 4 Posts
Top