Kawasaki Ninja ZX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've got a tech question for any body. My 2005 636 has 17k miles on it and the timing chain is making that horrific slapping sound at around 4k to 6k rpm. My local dealer has no tech bulletins on this. I've had the timing chain tensioner replaced twice, each time the noise goes away then returns later. help!
 

·
Premium Member
Joined
·
4,449 Posts
sound like its the chain at fault ...... stretched maybe....... just a stab in the dark.
 

·
Senior Member
Joined
·
11,782 Posts
Could be the chain. Might be a good idea to get a manual cam chain tensioner. You'd have to make sure you remember to adjust it but it may solve some of your problems.
 

·
Registered
Joined
·
7 Posts
If you put the manual cam chain tensioner on, just measure the chain stretch while you have the valve cover off. There is a spec for it in the book for my 04 so I would think the 05 book would have it also.
 

·
Registered
Joined
·
2,121 Posts
I've got a tech question for any body. My 2005 636 has 17k miles on it and the timing chain is making that horrific slapping sound at around 4k to 6k rpm. My local dealer has no tech bulletins on this. I've had the timing chain tensioner replaced twice, each time the noise goes away then returns later. help!
did you by chance have the valves adjusted at 15k miles?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top