Kawasaki Ninja ZX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi guys,

Im tearing my hair out trying to resolve this problem.

I bought a 2012 ZX14R six months ago and it had;
  • Full Yoshi Four into one system already installed.
  • It had been Woolich tuned
  • O2 sensor removed
For the first 3 months the bike ran fine. Hot Weather 35-45 deg celcius.
As it started to get colder here in Australia, it would stumble around 3k-4.5k rpm while cruising.
This hesitstion only happens in gears 4 5 and 6.
If I keep it in gears 1 2 and 3 the bike is perfect. 3rd gear on the freeway is not that much fun.

The bike has been reverted back to stock ecu settings and is not throwing any codes.(Never has thrown any codes)

I have replaced- Spark plugs, stick coils, air filter, fuel 98 back to 95.
I have checked the TPS, harnesses and vacuum tubing.
Checked all the earths and are good.


Any one got any ideas? Selling it is not an option.

Rod
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Will try the gas tank cap loose and see how it goes.
I took the bike to a dyno tuner Who was a woolich product seller. All these issues happened on the dyno and reverting the ECU back to stock seemed to help.
I rode it on Saturday and the problem is still there.
 

·
Administrator
Joined
·
58,483 Posts
You sure get hot there. We were 45C/113F yesterday
Too hot for me to ride
Odd that it gets cooler and starts running bad.
Maybe running lean from something else. But if you put ecu back to stock with a full yoshi system that might not be helping either
Sorry, I'm just thinking out loud lol
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Hey No worries.
Yeah I Just don't get it. I was thinking that maybe the ECU is the cause. The ECU is around 1k And makes an expensive experiment.
 

·
Registered
Joined
·
216 Posts
My 2016 did the same thing 30 minutes after I had the ecu flashed so of course that had to be the culprit. Turns out the filter in the fuel pump housing was bad. I would replace that as a starting point. Cost 6 dollars and 30 minutes of time.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
I get that a lot of these issues can be traced back to the fuel filter.
I don't understand how it is ok In the first three gears and is hesitating around 4k Rpm in the last three gears.

I don't think this one is the filter but I will check it to be sure.
 
1 - 8 of 8 Posts
Top