Kawasaki Ninja ZX Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
Sorry if this is a repost, just heard the ZX6Rs from '09 to '12 are being recalled for a faulty regulator/rectifier unit.

Has anyone had one fail?
 

·
Registered
Joined
·
158 Posts
Discussion Starter #4
It does!
 

·
Registered
Joined
·
3 Posts
Think yourself lucky guys... last summer my voltage reg. went and overcharged the battery, which then blew the ECU, speedo sensor and display, fan relay, taillight, hi beam and running lights.... you guys get the point. what a hassle im telling you. my bike was at the dealer all summer, parts were back ordered ect. my advice to anyone is get it fixed asap. Cheers
 

·
HEADBANGER
Joined
·
6,942 Posts
I'm hoping to hear about a job at a local Kawi shop tomorrow. Will be riding my bike to work the first day and tellin' them... "Order that sucker..."
 

·
Registered
Joined
·
26 Posts
I rode into the dealership on saturday after reading this thread on friday. The service manager asked what I needed and I told him I was here for the regulator recall for the 2009 Zx6r. He looked at me funny and asked how I heard about that, so I told him. He laughs, apparently he had only found out about the recall an hour earlier. Ahh, the information age... Ordered mine and will be the first from this dealership to get it done. :smile
 

·
Registered
Joined
·
1,890 Posts
I rode into the dealership on saturday after reading this thread on friday. The service manager asked what I needed and I told him I was here for the regulator recall for the 2009 Zx6r. He looked at me funny and asked how I heard about that, so I told him. He laughs, apparently he had only found out about the recall an hour earlier. Ahh, the information age... Ordered mine and will be the first from this dealership to get it done. :smile
Haha almost the same story with my dealer. I called them, the one guy I spoke to didn't even know about the recall yet, then the other guy told him while we were on the phone that he just got a notice about it. They ordered my part for me.
 

·
Registered
Joined
·
870 Posts
I would really like to install this myself as I don't really trust anyone to take apart my bike with the same care as I do. Do they have to install it or can I just take it and go?
 

·
Registered
Joined
·
10,439 Posts
I would really like to install this myself as I don't really trust anyone to take apart my bike with the same care as I do. Do they have to install it or can I just take it and go?
You just need to ask your dealer. My local dealer didn't even order the part unless I brought them my bike and left it :dunno

But just ask them.
 

·
Registered
Joined
·
870 Posts
Does anyone know what the new part # is?
The bad part # is 21066-0028
 

·
Registered
Joined
·
48 Posts
I would really like to install this myself as I don't really trust anyone to take apart my bike with the same care as I do. Do they have to install it or can I just take it and go?
Most likely not. The way it works is that Kawasaki is going to pay the dealership to fix it. So if they just give you the part they wont make any money.
 

·
Registered
Joined
·
26 Posts
I would really like to install this myself as I don't really trust anyone to take apart my bike with the same care as I do. Do they have to install it or can I just take it and go?
Mine is done. Took about a half hour max and they did not remove the plastics if that makes you feel more comfortable.
 

·
Registered
Joined
·
870 Posts
Just dropped my bike off today for the recall. I took the inside panel off for them so they wouldn't even think about taking the front end off. Since all I have is a small dealer here they won't order it unless the bike is in the shop already. Guess they need that money! lol On the flip side it is going to be raining for the next week and a half so not too worried about it.

I'm also interested to know why nobody was curious enough to find out what the new part number is since several of you have had it done? I think you should always check to see that parts were changed out when you get your bike back from being serviced.
 

·
Registered
Joined
·
89 Posts
a couple of months ago a blew a fuse after installing a new led brake light, dealership charged me $70( new bike new rider...dumb in know) could that have been caused by the regulator, because in my letter they said they will reimburse people for issues caused by the faulty regulator
 

·
Premium Member
Joined
·
594 Posts
Wow i am happy i saw this thread. I would not have known if it wasnt for this. Looks like i am going to have to call up the dealer and get this part in for me.
 

·
Registered
Joined
·
56 Posts
1 - 20 of 21 Posts
Top