Kawasaki Ninja ZX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a Kawasaki ninja ZX6R and it will not rev past 8000 Rpm in any gear any no matter if full throttle or not. But in neutral it will redline if I throttle it. What is the problem? Plz help me . Is the jumper mod safe?
 

·
Registered
Joined
·
3 Posts
Im having the same issue. I remapped the PC3 and it really didn’t help much. I reached out to a previous owner and he said he was told from the stealership that it needed a whole new wire harness. I find this BS. I was able to go from first to second and i backed off at 110 but then it had a tough time going above 60-70mph or 7-8000 rpm. I did have the tank professionally painted but i removed the pump and everything was taped off. I’m curious as to what “wire” would cause the lack of power? Also when I rev in neutral it will redline no problem. I’m think injectors fuel pump or filter? I was going to try the jumper mod but I do not know if i need to where it has the pc3 on it.
 

·
Registered
Joined
·
3 Posts
Im having the same issue. I remapped the PC3 and it really didn’t help much. I reached out to a previous owner and he said he was told from the stealership that it needed a whole new wire harness. I find this BS. I was able to go from first to second and i backed off at 110 but then it had a tough time going above 60-70mph or 7-8000 rpm. I did have the tank professionally painted but i removed the pump and everything was taped off. I’m curious as to what “wire” would cause the lack of power? Also when I rev in neutral it will redline no problem. I’m think injectors fuel pump or filter? I was going to try the jumper mod but I do not know if i need to where it has the pc3 on it.
I removed the power commander III tonight and still have the same issue. I was think maybe sync the throttle bodies? I’ve heard of a lot of different responses but I just want this fixed
 
1 - 5 of 5 Posts
Top