Kawasaki Ninja ZX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Cameras & optics Camera accessory Digital camera Reflex camera Electrical wiring

Motor vehicle Speedometer Gauge Steering part Measuring instrument

Finger Motor vehicle Gas Automotive battery Auto part

Tire Wheel Bicycle tire Crankset Automotive tire

Hi I have a 2000 Kawasaki zx 900e. Headlights just stopped working one night. Headlights don’t work now but sometimes come on when the bike is running. When they’re on the beam indicator is also on. When they’re off the beam indicator is off. Working on bike for a friend. I am an automotive mechanic so I have knowledge of electrical systems, use a power probe and read schematics just new to the zx bike. Questions I have are. 1 How does the headlight circuit work? 2 Where can I find a wiring diagram? 3 Where is the headlight relay located? 4 Where is the harness connector for the headlights located? Toggling the headlight switch does nothing. Tapping the switch does nothing. I looked inside the headlight switch and all connections seem fine. I checked at what I believe is the headlight harness connector based off the color wires in the switch Vs. the color wires at said connector and it looks fine no melts or corrosion. I checked the “head” fuse in the junction box it’s fine. How do I manually power the lights with a power probe? One last thing to mention is the plug at the back of the lightbulb, when the bike is running all three terminals are ground. What does that mean? Trying to figure out why the headlights were working then stopped, and now it kind of only come on intermittently most of the time off sometimes on for a brief moment then back off.
 

·
Registered
1993 Zx-7 L Model, 2006 ZX-10R
Joined
·
4,606 Posts
View attachment 21781
View attachment 21782
View attachment 21783
View attachment 21784
Hi I have a 2000 Kawasaki zx 900e. Headlights just stopped working one night. Headlights don’t work now but sometimes come on when the bike is running. When they’re on the beam indicator is also on. When they’re off the beam indicator is off. Working on bike for a friend. I am an automotive mechanic so I have knowledge of electrical systems, use a power probe and read schematics just new to the zx bike. Questions I have are. 1 How does the headlight circuit work? 2 Where can I find a wiring diagram? 3 Where is the headlight relay located? 4 Where is the harness connector for the headlights located? Toggling the headlight switch does nothing. Tapping the switch does nothing. I looked inside the headlight switch and all connections seem fine. I checked at what I believe is the headlight harness connector based off the color wires in the switch Vs. the color wires at said connector and it looks fine no melts or corrosion. I checked the “head” fuse in the junction box it’s fine. How do I manually power the lights with a power probe? One last thing to mention is the plug at the back of the lightbulb, when the bike is running all three terminals are ground. What does that mean? Trying to figure out why the headlights were working then stopped, and now it kind of only come on intermittently most of the time off sometimes on for a brief moment then back off.
1. Can you confirm that the low beams are having the intermittent issue?

2. All three terminals cannot be ground. Only one terminal is ground. Without looking at a wiring diagram to confirm, Both headlights might share the same ground.

@KevA do you have the wiring diagram for the zx9r E model?

3. There should be 1 or 2 headlight relay(s) under the seat next to the battery somewhere. Unless, looking at the last pic, those are the relays. IDK, need wiring diagram to confirm.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
1. Low beams and high beams don’t work when this problem happens. The beam indicator doesn’t even turn on when this problem happens.

2. When I unplugged the left connector at the bulb, testing from the motorcycle side of the harness all 3 terminals read ground according to the power probe.

3. I’ve been looking for a wiring diagram but like I said I’m new to motorcycle repair so I don’t know where to look. Yes I’ve tried Google but I don’t know what years and models jive. What connector is for the headlights? I believe it shows behind the instrument cluster in my pictures.
 

·
Registered
Joined
·
451 Posts
Nearest I've got is a C Model but the Headlight circuit will be the same for the E apart from the C has a single Bulb whereas the E is Foxeye (Twin)
I suspect your issue is the Head Light Relay situated inside the Fuse Box see:-
ELECTRICAL SYSTEM 15-59 onwards for details in the attached Manual.
ZX9R C Manual
 

·
Registered
80,81 GS750L, 81 XS1100, 85 FJ1100, 96 GPZ11 (1200 EFI PROJECT), 03 VT11, 06 VT600, 12 ZX14R, 67 C20
Joined
·
137 Posts
3-pin headlight connector ground/high/low. The switch is strictly for high/low. Key on hot at all times. B careful w ur power probe as u hopefully know. 2 model generations of zx9, efi and carb. Wiring will b the same for lighting and very little else will have changed. Sounds like a wiring issue tho. Old/cracked wire(s) or mice. Usually relays stay bad when they go. But cant rule it out based on "usually"
 
1 - 5 of 5 Posts
Top