Kawasaki Ninja ZX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
313 Posts
Discussion Starter #1 (Edited)
I have a 1993 Kawasaki ZXR 750 I just picked it up and got it started and well Im not sure what to do. I can start the bike but the idle is so messed up in the begining it runs so high that flames shoot out of the exhaust then when I warm it up and take th choke off it will roughly idle for a second but it will keep kutting off so i rev it a little and it will either bog down or I can get it to rev up but it pops out of the carbs a bit just wondering if anyone has any ideas on where I should start looking first. i dont mind spending money on it I just dont want to fix anything that aint broke....

Ps I am currently a automotive mechanic so i have a great knowledge about the internal combustion engine so feel free to use big words itll confuse the newbies lol......
 

·
Banned
Joined
·
3,608 Posts
Start with K.I.S.S. Keep it simple stupid. Check vac lines, carb sync, and carb cleanliness. I would start with cleaning the carbs and make sure everything is the same across the rack. The pull the bowls and clean clean clean clean..
 

·
Registered
Joined
·
497 Posts
Yup I am with u on the carb cleaning. A nice good cleaning of the carb and the jets will likely solve the issue. Also invest in some new plugs. Amazingly these can run on 2 plugs! So check spark on each pack.

I am willing to bet 5 or 6 hours of work and some plugs would solve your issue.
 

·
Quinton Phuckin Tarantino
Joined
·
18,914 Posts
These symptoms are usually carb or plug issues as stated above .
 

·
Registered
Joined
·
313 Posts
Discussion Starter #7
Thanks guys actually you all were right the carbs were leaking air on the backside where they mount up to the intake so I removed and reseated them and she purrs now.
 
1 - 7 of 7 Posts
Top