Kawasaki Ninja ZX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
224 Posts
uuuuummmmm pics
 

·
Registered
Joined
·
9 Posts
Cant post new thread

Sorry, but I just have not figured out how to post my own thread, so I wrote it here:

I have owned a 1900 H2 since 1995 (second owner) Thing is mint, never overheated, taken good care of. Now Im seeing milk in the oil. Obviously coolant, since my resevoir has gone down as well. Question is, has anyone heard much in regards to head gaskets being an issue with these? I took out the water pump, and it really doesnt look like the coolant is getting into the case from there. The amount lost from the coolant resevoir is about a pint.I see the pump is no longer available, so in the least I was hoping to replace any seals before putting it back in.

Thanks
 

·
Registered
Joined
·
4,649 Posts
Wow that's clean! :clap
 

·
Registered
Joined
·
152 Posts
Sweeet! :crazyloco

Rare to see one in such good condition. Ride it and enjoy it but keep it safe.





Not to hijack but rv750, unless you've ran it hot or detonated it then it's your water pump. Most of the time they will leak from the weep hole first but not always. I just had the same problem with mine. No apparent leaks but as soon as I started it, instant milkshake. Pulled the pump, filled it with water and put air pressure to it and it started leaking at the end seal. Still did not leak at the weep hole though. I was looking for other solutions and ended up getting a killer deal on a used pump from a part out but here is a link to my earlier thread on the same issue of pump availability.

http://www.zxforums.com/forums/zx-7r-forum/64954-h-model-water-pumps.html

HTH :smile
 
1 - 10 of 10 Posts
Top