Kawasaki Ninja ZX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey everybody. I am in some desperate need of help. My bike has left me stranded twice now, all because the battery is not being charged. I have checked the stator, at 4k it is putting out 66v volts ac on all three legs, im testing .11 on all three legs for resistance. I have tried 2 different voltage regulators and still no change. What am I missing here? Please help as I need to make a 300 miile ride to dealer on wednesday to get the voltage regulator swapped under recall.
Any help is greatly appreciated. Oh, just another detail, bike was in 2 accidents. one in feb of last year, downed it riding a wheelie, had to put new stator and cover. Bought new Oem Stator. Also replace voltage regulator when that happened. And in October, a school bus pulled out if front of me and my wife and I downed in hard on the right side. I have bazzaz installed, and xtre, servo eliminator mod.
On a side note, the bike ran out of gas, but the light never came on.
Thanks
:banghead
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
also, tested the exciter wire going into the regulator, tested positive for 3.78 volts plus or minus a few due to battery fluctuation, white wire tested positive for 12 volts and the black and yellow tested fine for ground. I have completly lost my mind here. I did notice that if I unplug my headlights (HID) ballasts, it will slowly bring back up the charge. This is what led me to replace everything last year. Could this be a sign of a bad regulator? :banghead
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
not yet. i need to take it to san antonio to get it done. I live around 2 hours south of sa. Scheduled for wednesday, but at this rate, dont look like im going to make it lol.
I did get the notice, but at the moment, i dont trust taking my baby out the driveway due it her leaving me stranded.
 

·
Premium Member
Joined
·
2,471 Posts
I seem to remember someone else having a similar problem a while ago. It happened to be a part of his wiring loom was rubbing and it rubbed through a couple of wires.

Maybe wirth inspecting some of the wiring loom for rubbing/chaffing ?
 

·
Premium Member
Joined
·
15,095 Posts
Sounds like a pinched wire, loose connection or corrosion to me.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
I thought about that too, but everything else works great. Most of my factory harness has been moved around for the bazzaz, but I will check it out today.
As far as corrosion, my baby dont have none of that lol. I check my battery connections once a month and all the grounds are coated with that clear icky stuff to block out water.
I will look at the harness today after work.
 

·
Registered
Joined
·
18 Posts
I had the same issue, Kawi dose not even manufacture the regulator/ rectifier any more either, you have to look into the after market for it. I found one for like $95 at 2wheelpros.com I do balieve it comes with everything you need, but I too need to confirm that
 

·
Registered
Joined
·
1 Posts
holy crap whats up with the charging systems on the 09-10, so i replaced the stator on my bike almost a year ago due to a spill, and now my the charging system took a dump again, last time the stator wires melted and grounded out giving me continuity to ground so it was obvious it was a bad stator, this time though not so much, the first thing i did was buy a new battery hopeing it would be an easy fix...... that didnt work. so i researched and found the recall on the regulator, got that swapped out at a dealership and it died on the way home! so i took it apart to test the stator. the resistance checks out around 1-2 ohms which is good. but the output voltage is around 5-10 vac which is ridiculously low should be around 54 vac , the manual says if the resistance is good but the voltage is bad to replace the rotor, i dont want just throw parts at it, but could the rotor magnets rely be bad or should i just replace the stator because it would be the easiest thing to change out first?
 
1 - 9 of 9 Posts
Top