Kawasaki Ninja ZX Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
i have an 07 zx6r with bout 3500 miles on it, only aftermarket part is a K&N air filter. prob im havin which just started a few days ago, is that while im ridin under WOT past 9k rpm it feels like the motor take a nose dive. seems like it dont wanna rev anymore, real draggy. but if im not in gear or stopped it revs real fast and smooth all the way to red line. no missing or anything. i did notice that if i back off the throttle just a hair it seems to start pickin up power again. Anyone had anything similar happen to them? any help would be greatly appreciated. im tryin to ride these last few weeks of nice weather before i have to put it in the shop. :banghead
 

·
Registered
Joined
·
172 Posts
try taking out the air filter and putting it back to stock and see if the problem goes away, if it does, the air filter is probably causing you to lean out just slightly in that RPM range. if this is the case maybe a PCIII could help?
 

·
Registered
Joined
·
103 Posts
The air filter is most likley the cause. Its sucking in more air but the computer doesnt compensate by adding more fuel like it should. Return it to stock filter or buy a PC3
 

·
Registered
Joined
·
103 Posts
Could be a lose bolt vibrating, the ram air getting loose(common prob on kawis), to be honest just check for loose parts, if you cant find anything i wouldn't worry too much
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #9 ·
K last night after work i changed the Air filter back to the stock one, it seems like it got a little better. But it still drags it feet past about 9k.... I herd someone says something about secondary injectors maybe not coming on, or fuel pump? any ideas. . . i really wanna get it fixed before i put it away 4 the winter so i dont dead with it next year. I'll just sell it and get a zx10 :evil Also i forgot, my email address is [email protected] if u wanna reply there. Thx a bunch u guys. Ride safe.
 

·
Registered
Joined
·
103 Posts
If the bike is stock now and still hesitating past 9k then bring it to the dealer. Should still be under warranty no?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #11 ·
Just noticed today its more about 12 up to redline now instead of just past 9 like it was. Yeah its still under warranty, just was hoping for a quick fix, seein as there isn't to much good ridin weather left where im at :banghead . . . Also what all should they cover if i take it in? Are they gonna hit me with a hugh shop bill if its something i coulda fixed on my own? thanks again for the info.
 

·
Registered
Joined
·
18 Posts
That hesitation is normal since you have flaps in your exhaust for noise emissions. If you turn off those flaps in your end muffler, that hesitation will go away. You can either disconnect the cables operating it (not the motor, just its cables controlling the flaps), or do the jumper mod. Search for it, you'll see how it is done.

Just noticed today its more about 12 up to redline now instead of just past 9 like it was. Yeah its still under warranty, just was hoping for a quick fix, seein as there isn't to much good ridin weather left where im at :banghead . . . Also what all should they cover if i take it in? Are they gonna hit me with a hugh shop bill if its something i coulda fixed on my own? thanks again for the info.
 

·
Registered
Joined
·
37 Posts
mine starts to make that buzzing noise also, but when i roll on the throtle more it goes away, but when its in that rpm range sounds like the exhaust is going to vibrate off.
 

·
Registered
Joined
·
80 Posts
i would take it back to the dealer and see what they say. if they are no help (which i will bet they won't be), try the jumper mod. easy to do and apparently works like a charm. good luck!!!
 

·
Registered
Joined
·
37 Posts
For those of you experiencing the vibration at ~9k rpm, it's probably your clutch lever. Try putting one or two fingers on the lever at that rpm and see if it stops vibrating.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #17 ·
did the jumper mod tonight and noticed almost all hesitation is gone. still dont understand why a K&N filter made that big a difference. Anyone think i should try stick it back in after i did jumper mod or not gonna work still? Thanks again as this info been great.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #19 ·
k, gonna put the K&N back in tonight, also anyone herd of taking off, or hollowing out the undertail muffler? im not lookin for a real performance gain just a cheap better sound, till i decide weather or not i need to buy a PCIII. cause if i end up needing one, i'll just go full length exhaust. Thanks again guys.
 
1 - 20 of 22 Posts
Top