Kawasaki Ninja ZX Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
Alright my bike will not start it will crank but not fire. The battery did die in the process of trying to start it so i tried to jump it and the same result. I am getting fuel but no spark. I have no voltage going to the coils. I have a spare ecu and no luck with that. The fuel is clean and fresh. The only outside condition was we had a bad thunderstorm ehen i was at work. The bike also had s pcIII and a two bros Exhaust but currently is all stock. Ive changed the plugs and am not getting any codes.. please help
 

·
Registered
Joined
·
602 Posts
Did you check fuses? There is one for the ignition and one for the ECU.

Also, the crank sensor controls spark, make sure you are getting a signal.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #4 ·
Alright i am now getting voltage to the plugs... but if i ground it to the frame i still have no spark
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #6 ·
Ok battery plugs and all sensors checked out ok. I have an extra ecu so i ruled that out as well. How do i check the ignition switch
 

·
Registered
Joined
·
602 Posts
You get a volt meter and see if there is power going through the switch when in the on position.


Also, you wouldn't happen to have a chipped key would you? There will be a light that flashes on dash when the bike is off if you have it.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #8 ·
Didnt noticed a flashing light when it was off but I will check when I am off work and wouldn't the gage and everything powering up show the ignition switch is working
 

·
Registered
Joined
·
602 Posts
yeah it would and you said you were getting spark right? so that would mean the engine kill switch is working too.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #10 ·
It cranks but i dont get a spark... if the kill switch was bad wouldnt the starter not work?
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #11 ·
Well tommorrow i have time to work on it and ill check everything yet again and if nothing then im breaking down and its going to the stealership
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #12 ·
Dropped it off today they said they wont get to it for a few days...already been a week with at the bike and im having withdrawals lol
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #13 ·
K my first$100 of diagnostics went into finding i had no spark...which i already told them. And they said my gas tank was 1/2 full of water
 
1 - 13 of 13 Posts
Top