Kawasaki Ninja ZX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
My bike is shooting code 23 camshaft sensor malfunction. I replaced the sensor and i am still shooting the code. The symptoms are the bike will not rev above 12k. Its not the ecu or sub tps or exhaust servo. Any ideas?
 

·
Registered
Joined
·
519 Posts
Check your plugs peekster. And spark.
 

·
Registered
Joined
·
517 Posts
12K? 12,000 RPM! You're complaining it won't go higher?! Where does that thing redline? Do you really spin it that fast a lot? Not trying to be facetious or anything. I really don't know where your bike redlines, but more than 12,000 RPM thats way up there.
 

·
Registered
Joined
·
5,528 Posts
12K? 12,000 RPM! You're complaining it won't go higher?! Where does that thing redline? Do you really spin it that fast a lot? Not trying to be facetious or anything. I really don't know where your bike redlines, but more than 12,000 RPM thats way up there.
Well I have an 05 and redline is near 16500 you may be able to see it here, this is me at the track.

 

·
Registered
Joined
·
517 Posts
Wow! I thought 11,500 on my ZX11 was high enough. I've had it to 10,000, once. Guess its not to hard to figure out I don't do any racing. I did like your video. Looks like that would be fun but I don't heal up as fast as I used to. 16,500 just seems incredible. Do you know what kind of piston speed you're generating at that RPM?
 

·
Registered
Joined
·
519 Posts
My bike is shooting code 23 camshaft sensor malfunction. I replaced the sensor and i am still shooting the code. The symptoms are the bike will not rev above 12k. Its not the ecu or sub tps or exhaust servo. Any ideas?
And you may have a short to ground somewhere, check those wires make sure they arn't bare.
 
1 - 7 of 7 Posts
Top