Kawasaki Ninja ZX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
this is my first time actually posting on the forums so i would like to start off saying hey to everyone.

i am having an issue with my 06 zx6r. for starters i laid my bike down pretty hard on the stator side a few months ago now i finally got it all rebuilt i started her up an she ran for about 2 min then died on me first thing i did was check my regulator/rectifier that was bad so i replaced it then same problem then i checked my stator that was bad so i replaced it along with my battery then i thought that i was good to go until a few weekes ago and she cut off on my while i was riding discovered the charge was not comming back to my battery the test on the stator was good then then test on the regulator was bad so i put in a new regulator again i tested the battery after i replaced the regulator and that did the trick by battery was charging again :smile reading between 13-14 volts so now im riding yesterday heading to daytona and what do you know she just dies on me again but some of the charge went back to the battery around 11.7 -12 volts (enough to start her back up )so once again i test the stator and regulator and they were reading good but i disconnected the battery (- side) and what do you know bike shuts off. SOMEBODY PLEASE HELP MY BABY
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
i got a buddy that an electrcian in the navy an i had him check it for grounds but i have none. i was able to ride it all the way home yesterday pushing 90+ i was afraid to let off the throttle cause i knew it would die then i get about 5 miles from home an it starts to cut off on me i hit the start switch an roled on the throttle and what do you know she starts right back up
 

·
Registered
Joined
·
602 Posts
I am pretty sure taking the neg terminal off and the bike dieing is normal because you are breaking the circuit for everything. The way you explain it, it sounds like charging/battery problem. Because if your battery is draining there is either a r/r, generator, or wiring problem or even the battery. Recheck everything.
 
1 - 4 of 4 Posts
Top