ZX Forums

ZX Forums (https://www.zxforums.com/forums/)
-   ZX-7R Forum (https://www.zxforums.com/forums/zx-7r-forum/)
-   -   Lapping kit oil pump. (https://www.zxforums.com/forums/zx-7r-forum/204540-lapping-kit-oil-pump.html)

ritchie-t 07-20-2019 10:54 AM

Lapping kit oil pump.
 
Just wondered if anybody has fitted a new kit oil pump and it been a bit on the tight side? It feels like if I pushed it in I wouldn’t get it out again. It would be an interference fit. I know it needs to be snug, but this is too tight.

Looking at the kit manual it does say that if the kit pump is too tight then to lap the surface to make it fit. So I assume this was not uncommon back in the day.

I can always go to a machinist to get this done, but I was wondering if I am missing a trick not doing it myself. Has anybody done this? If so, I would be curious to know what method is used. With the shaft hole going through off-center it makes it a challenge to spin perfectly central.

ninjanut 08-05-2019 08:32 AM

Probably the only one on here with any experience with kit parts would be CCM. Most of us don’t have the need (racing like you) so never bother with exotic parts. Is there any other parts that need to be used in unison with the kit oil pump?


All times are GMT -7. The time now is 09:40 PM.

Powered by: vBulletin 3.8.8
Copyright ©2005-2010 - www.zxforums.com
Website designed and developed by Random Computers
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome