No spark! - ZX Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 11-01-2019, 12:15 PM Thread Starter
Newbie
 
Joined: Nov 2019

Posts: 3
No spark!

I have a 2006 zx6r it sat in the rain one night and I haven’t had spark since I put new plugs in it tested the coils swapped the computer tested the kill switch put a new ignition in it did the stator did the pickup coil did the fuel pump swapped the battery and nothing is working also when I try to start it the FI light flashes NEED HELP it’s been 8 months
Russellmax36 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-01-2019, 04:23 PM
Member
 
Strider's Avatar
 
Joined: Oct 2019
From: Texas
I Ride: 2009 ZX-6R

Posts: 45
Hello and welcome!

Does the engine try to turn over, or is there just no response at all when you push the button?

If there is no response at all, then it could be the clutch lever switch or the kick stand switch.

2009 ZX-6R (65,695 miles and counting) | www.ZX6R.us | www.Seaton007.com
My YouTube Channel
M4 GP Slip-on | ASV C5 Levers | Spiegler SS Brake Lines | SpeedoHealer V4
Custom FE | K&N Air Filter | Vortex Sprockets -1/+2 | EK MVXZ Chain
Strider is offline  
post #3 of 4 (permalink) Old 11-03-2019, 04:53 PM Thread Starter
Newbie
 
Joined: Nov 2019

Posts: 3
It turns over just doesn’t fire I checked all the plugs I have no spark
Russellmax36 is offline  
post #4 of 4 (permalink) Old 11-08-2019, 05:08 AM Thread Starter
Newbie
 
Joined: Nov 2019

Posts: 3
Anyone ???? I NEED HELP
Russellmax36 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome