Somethings not right about my 08 Zx6r!!! - ZX Forums
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 04-06-2019, 12:01 AM Thread Starter
Newbie
 
Joined: Apr 2019

Posts: 1
Somethings not right about my 08 Zx6r!!!

I just recently bought My 08 Zx6r and it is my first bike and I bought it as a project but I have run into a problem and I noticed when I am in 1st gear and I accelerate it will get around 9,000RPMs and it sounds like I’m in the red line and the Engine keeps getting louder and louder. Just wondering if anybody has a solution to my problem.
RaymondHerrera is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-06-2019, 02:51 PM
Senior Member
 
Snakes709's Avatar
 
Joined: Nov 2009
From: Edmonton
I Ride: 2018 H2 SX/SE

Posts: 782
Garage
Confused by the way you worded it. Correct me if im wrong. You accelerate and at 9,000rpm but it sounds like its bouncing off the rev limiter. Does it not go past 9k?

2018 H2 SX/SE
Snakes709 is offline  
post #3 of 7 (permalink) Old 04-09-2019, 12:10 PM
Senior Member
 
Joined: Jun 2014
From: Rhode Island

Posts: 164
Probably fine my 05 636 just starts waking up around 9 grand .

!990 zx 7
1985 gpz 750 turbo
1981 gpz 550
1983 gpz 550
1990 fzr 400
1982 gpz 750
riturbo is offline  
post #4 of 7 (permalink) Old 04-09-2019, 08:06 PM
Senior Member
 
keepitgreen's Avatar
 
Joined: Jan 2014
From: Central TX
I Ride: 2003 ZX7R-Green..

Posts: 1,258
Being an 08, check w dealer to make sure all recalls were done on the bike.
They can check vin# for recalls.


Sent from my E6910 using Tapatalk

2003 ZX7R - Green, named Katie
1998 ZX7R - Endurance body, named Frenchie
keepitgreen is offline  
post #5 of 7 (permalink) Old 05-15-2019, 01:00 PM
Senior Member
 
Joined: Jan 2012
From: Okemos

Posts: 602
Check to make sure the subthrottle actuators are opening. They are supposed to be full open at that rpm. If they are stuck closed it will prevent airflow.


Check for good fuel pressure. Low fuel pressure will be able to keep up at lower rpms but will keep power from building in the higher rpms


Check that the secondary fuel injectors are working, they progressively start at around 6k and then I think they hit 100% after 10k.


Very last thing to check would be coils.
cive is offline  
post #6 of 7 (permalink) Old 05-17-2019, 02:14 PM
Newbie
 
Joined: May 2019

Posts: 1
2009 ZX6R won’t ride past 8k rpm

Hey guys I’m new to the forum and I’m having some trouble. I bought an 09 zx6r and the bike ran good for a while. After some time I started loosing power past 8k rpm. I then took it to the shop and he cleaned the throttle body ran codes and nothing but I was able to go to about 10k rpm at this point and he said it could possibly be that my ecu is bad. Does anyone have an opinion on this? It has a quick shifter graves slip on and the previous owner told me it was flashed but no dyno jet or anything. I was thinking of getting a dyno jet and new ecu for the bike but before I go spend the money I figured I would try and ask around
Thanks for any help
Tommycraigsisk is offline  
post #7 of 7 (permalink) Old 05-18-2019, 05:38 PM
Senior Member
 
Joined: Jan 2012
From: Okemos

Posts: 602
See my previous comment.
cive is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Somethings loose or not 100% somewhere up front (help) DROPFORGEDSTEEL Mechanical & Technical 24 07-04-2011 04:00 PM
somethings odd about this craiglist scooby ZX-7R Forum 5 06-03-2010 04:08 PM
Uh oh Somethings leaking.. II Lun4r II ZX-6R Forum 10 05-03-2010 12:46 AM
Somethings not right- clutch? ICE UM ZX-7R Forum 2 03-22-2009 04:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome