ZX Forums - Reply to Topic
Thread: Speedo Cable Pic? Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-04-2013 07:09 PM
SpeakerBox
Quote:
Originally Posted by nwlzch85 View Post
certainly glad to hear you got it all worked out. and yeah, adjusting the shift lever to your foot is a great thing! not all of us are 5'6 or 6'5... make it so its comfortable to be under, but then rmmbr to not make it so high that its a bear to shift down. ;)
Yeah, I adjusted it, sat on the bike, adjusted, sat on the bike. Gonna try to take it out again by like wednesday to make sure it's where I want it though. Hopefully it doesn't rain on Wednesday so I can ride.
02-04-2013 06:17 PM
nwlzch85
Quote:
Originally Posted by SpeakerBox View Post
I looked at it yesterday before I went for a ride and thought it was broken. Looked a little deeper and found the nut that screws onto the cluster so it went back on fine. I started riding yesterday and noticed that shifting was pretty uncomfortable as well and I had to point my foot at the ground to get under the shift lever. Got home and adjusted the shift arm(whatever it is) and all is fine. I didn't know it could be adjusted at all but its fine now thankfully.
certainly glad to hear you got it all worked out. and yeah, adjusting the shift lever to your foot is a great thing! not all of us are 5'6 or 6'5... make it so its comfortable to be under, but then rmmbr to not make it so high that its a bear to shift down. ;)
02-04-2013 08:10 AM
SpeakerBox
Quote:
Originally Posted by nwlzch85 View Post
lol. yeah common problem, they vibrate themselves loose. i used some plumber's tape and it solved the problem. just wrap the end with a layer or so, then screw in tightly. ;)
I looked at it yesterday before I went for a ride and thought it was broken. Looked a little deeper and found the nut that screws onto the cluster so it went back on fine. I started riding yesterday and noticed that shifting was pretty uncomfortable as well and I had to point my foot at the ground to get under the shift lever. Got home and adjusted the shift arm(whatever it is) and all is fine. I didn't know it could be adjusted at all but its fine now thankfully.
02-04-2013 12:06 AM
nwlzch85 lol. yeah common problem, they vibrate themselves loose. i used some plumber's tape and it solved the problem. just wrap the end with a layer or so, then screw in tightly. ;)
02-02-2013 03:59 PM
SpeakerBox
Quote:
Originally Posted by JoelKnauber View Post
You can buy a converter that screws into the speedo drive and interprets the signal right there. Then it's just a wire coming up to connect to an aftermarket gauge. What you posted won't work on your factory gauges at all.
The first thing I posted is from Dakota Digital, it's an adapter for mechanical to electronic or at least appears to be. Their descriptions are pretty vague IMO so it's hard to tell. I'm not trying to wire in my current analog gauges, just something like a zx14 or zx10 or something newer with a digital speedometer and analog tach or maybe something aftermarket but I figured I could find a decent gauge cluster locally at a decent price from someone parting out a wrecked bike or something. It's just a thought, if it seems like it'll get a bit too expensive then I won't go through with it. I just want something a little different and this cable breaking brought up the idea.(which I'm sure isn't the first time it's been brought up around here)
02-02-2013 03:50 PM
JoelKnauber I actually just had some superglue laying around the last time it came off for me. It still stuck on there in my spare parts bin in the garage. hahaha
02-02-2013 03:24 PM
Masta Squidge Mine fell off repeatedly, so I went to the place I bought it from and commandeered a bottle of blue loctite. Been on for over a year without problem since.
02-02-2013 03:22 PM
JoelKnauber You can buy a converter that screws into the speedo drive and interprets the signal right there. Then it's just a wire coming up to connect to an aftermarket gauge. What you posted won't work on your factory gauges at all.
02-02-2013 10:17 AM
SpeakerBox If I had the machining equipment and skills, I'd do this for sure and it seems like a viable solution for someone to make and sell to the Kawi community. Would anyone be up for trying something like this?

http://www.badweatherbikers.com/buel...tml?1202407572
02-02-2013 10:04 AM
SpeakerBox Would doing the conversion get me somewhat close? Has anyone done it successfully and it being accurate or at least close?
02-02-2013 09:09 AM
JoelKnauber You don't have to pull the cowl, I did that on the side of the road a couple times before I ditched my speedo. You can just reach in there and thread it back on, NBD. If you want, throw some loctite on there to make sure it doesn't happen again.

Digital speedos are usually driven by a sensor on the front sprocket, or a hall effect on the front wheel. The trouble with trying to use the stock cable is that turn ratios and what not come into effect, and not all bikes are equal.
02-02-2013 07:57 AM
SpeakerBox Has anyone used something like this to convert over to a digital speedo gauge?

http://www.dakotadigital.com/index.c...rod/prd242.htm
02-02-2013 07:44 AM
SpeakerBox
Quote:
Originally Posted by Bozo View Post
it just screws onto a fitting on the rear of the cluster. And yes, it is fairly common for them to vibrate loose and disconnect. You should be able to get it back on with a couple of fingers, and it will hold until you decide to pull the front cowl.
Awesome, that's exactly what I wanted to hear. I'll have some time tomorrow to take a good look at it and do what needs to be done until I pull the front cowl. Guess I'll add that to my list when I take it apart to put my race fairings on it after I do a bit of repair and paint work on them. Thanks bro.

So this got me thinking a bit. What do other bikes with digital speedo's use instead of a cable like on the zx7 and older bikes?
02-01-2013 07:34 PM
Bozo it just screws onto a fitting on the rear of the cluster. And yes, it is fairly common for them to vibrate loose and disconnect. You should be able to get it back on with a couple of fingers, and it will hold until you decide to pull the front cowl.
02-01-2013 03:42 PM
SpeakerBox I know, I know, I should've taken a picture and posted it and you guys could've told me if it was broken but I had to drop the bike off at home and pick up the girlfriend and she doesn't ride with me right now and I completely forgot.(we recently found out she's pregnant! (-: )
02-01-2013 03:39 PM
SpeakerBox
Speedo Cable Pic?

So I'm riding today since it's an absolutely beautiful riding day and about 50 degrees out. I was doing around 40mph and decided to take a quick glance down to see if I was correct and according to my speedo, I was doing 0mph. lol Got to a red light and looked to the left of the cluster and there was the speedo drive cable. lol Does anyone have a picture of how it attaches to the cluster? I want to figure out if it's broken or came loose somehow before I take the front down to try to figure it out.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome