ZX Forums - Reply to Topic
Thread: No spark! Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-08-2019 05:08 AM
Russellmax36 Anyone ???? I NEED HELP
11-03-2019 04:53 PM
Russellmax36 It turns over just doesn’t fire I checked all the plugs I have no spark
11-01-2019 04:23 PM
Strider Hello and welcome!

Does the engine try to turn over, or is there just no response at all when you push the button?

If there is no response at all, then it could be the clutch lever switch or the kick stand switch.
11-01-2019 12:15 PM
Russellmax36
No spark!

I have a 2006 zx6r it sat in the rain one night and I haven’t had spark since I put new plugs in it tested the coils swapped the computer tested the kill switch put a new ignition in it did the stator did the pickup coil did the fuel pump swapped the battery and nothing is working also when I try to start it the FI light flashes NEED HELP it’s been 8 months

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome