ZX Forums - Reply to Topic
Thread: 99 zx9r C2 carbs 😡 Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-26-2019 05:01 PM
Dropagear That's exactly what's going on. . Wish it had a fuel gauge...
08-26-2019 03:30 AM
ninjanut When you run without a pump, the back/bottom of the tank is actually lower than the carbs. This would be why it stops running when low but runs fine when full.
08-25-2019 07:16 PM
Dropagear No the hose isn't pinch but when the tanks low on gas is not filling the carbs.. as long as the tanks full I'm good... I check I original fuel rely and it's testing bad... Got a new one and it's testing bad... Seen a fuel pump i think I'm going to order it... It bypasses the rely and cuts out when it get 3psi..
08-24-2019 05:25 PM
ninjanut Fuel hose getting pinched under tank? Is it the OEM moulded hose?
08-23-2019 07:26 PM
Dropagear Thanks for the tip... Yes they had new seals.. Recleaned carbs put them back on running good.. But I think I found my problem.... I bypassed my fuel pump and ran fuel line straight from the tank to carbs with filter in line because I was having issue with pump and didn't feel like dealing with it.. Any way I noticed when I sat the tank down on the bike, running, it started running like it was missing... I lifted tank back up and it started running fine... So now I'm back on fuel pump rely and wiring to figure out why the pumps losing power after it starts.. And im ordering carb syn tool . Let u know what comes up
08-21-2019 02:29 PM
Chevy Fan Attic
Quote:
Originally Posted by Dropagear View Post
Ordered k& l carb repair kit, float valve needle and seat, installed it and now it's leaking worst than before.. smh back out they come again.. I'm never paying another bike with carbs.
As mentioned did the o rings come with the kit? Make sure all the floats dont have gas in them because of a crack.
Take the carbs off and get all the gas out of them. take off the bowls and inspect.
Once you get the carbs all put back together with the bowls OFF but not on the bike, hook a hose to the fuel inlet that feeds all the carbs. flip the 4 carbs assembled upside down and blow air into the line. You shouldn't be able to blow air through. Keep feeding air into the line and 1 carb at a time manually open each fuel valve and air should start coming thru, then close and no air flow. Do that for each carb and make adjustments to get all 4 working. Also when the carbs are upside down make sure the floats are all level.
Its a lot easier to get all this working off the bike.
08-21-2019 01:22 PM
ninjanut Did the kit include new o-rings on the seats?
08-20-2019 06:13 PM
Dropagear
99 zx9r C2 carbs 😡

Ordered k& l carb repair kit, float valve needle and seat, installed it and now it's leaking worst than before.. smh back out they come again.. I'm never paying another bike with carbs.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome