ZX Forums - Reply to Topic
Thread: BRAND NEW ZX-14R ABS SE FRONT BRAKE MAKING “CLICKING SOUND” when applying at low spee Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-20-2019 07:19 PM
185EZ It's a death trap!
I'll take it off your hands for $8000 to save your life
08-20-2019 06:12 PM
ZX-14RipperSFV
Quote:
Originally Posted by hammerhead View Post
it's just the pads rattling. Nothing to be concerned about.
thanx!
08-20-2019 04:53 AM
Hammerhead It's just the pads rattling. Nothing to be concerned about.
08-20-2019 12:33 AM
ZX-14RipperSFV
BRAND NEW ZX-14R ABS SE FRONT BRAKE MAKING “CLICKING SOUND” when applying at low spee

Hi all, so I just got a BRAND NEW 2018 ZX-14R ABS SE about 3 weeks ago and I’ve put about 570 miles on it and recently noticed the front brakes make this “clicking sound” when applying them at low speeds or when just pushing bike. Now this is my first bike I’ve ridden that has ABS and Traction Control, is this just something to do with either of those systems or is it something that I need to address?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome