ZX Forums - Reply to Topic
Thread: Repeated fuel pump failure of zx7r Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-24-2019 08:34 AM
gr8skyr When my ZX7R fuel system, carbs were overhauled, I heard the same thing about aftermarket fuel pumps from ebay, etc. You pay for what you get. My original OEM fuel pump lasted almost 20 years. So when it was time to finally replace it, I figured it was worth the $220 at the time to buy something I wouldn't have to tear out and replace in couple years.
08-14-2019 09:51 PM
57x
Quote:
Originally Posted by ninjanut View Post
If you hook the pump up directly to 12v supply, it should pump continuously if the bowls are empty. Usually I will drain the bowls, unplug the pump and connect two jumper wires from pump to the battery. Once connected, the pump should run steady until the bowls are filled and then stop. If the pump works in this situation, you need to look elsewhere for the cause.
You can do the same routine by putting the bike in gear, kickstand down, clutch lever out, hit the start button. This is a carburetor priming circuit.
08-13-2019 12:43 PM
ninjanut If you hook the pump up directly to 12v supply, it should pump continuously if the bowls are empty. Usually I will drain the bowls, unplug the pump and connect two jumper wires from pump to the battery. Once connected, the pump should run steady until the bowls are filled and then stop. If the pump works in this situation, you need to look elsewhere for the cause.
08-12-2019 07:02 PM
Adren_x Thank you Mr. ninjanut for your reply.

After I posted above, I exchanged broken one to new one (they are same product. I had bought 2EA at once).
The engine run successfully with new pump, but soon, gasoline was leaking from new one...hahaha.....

Other friend who is also experienced owner of 7R said like you ^^ "Crap Chinese fuel pumps!"
He said a failure and leaking is pretty normal for cheap chinese fuel pumps from ebay, aliexpress, etc.

Genuine fuel pump price of Kawasaki is over 300$,
and I'm not sure that there won't be a failure again on that expensive one.
so I will upgrade the pump from cheap one to better(more expensive)one step by step until there won't be a failure again.

I already got 2EA of other fuel pumps for replacement from ebay, they are still cheap, but little more expensive than current one.
Not like current one, rubber bracket and extension wire are included, and it looks better.
I hope this new one will work well.
05-31-2019 01:23 PM
ninjanut Crap Chinese fuel pumps. I have only used OEM and replaced once (10 years ago). I have never had OEM fail due to quality. They simply wear out the contacts. I have replaced a set of contacts on my old OEM pump with aftermarket and they don’t last too long (2-3 years).
I think you may have something else going on that is causing the issues.
05-30-2019 07:15 PM
Adren_x
Repeated fuel pump failure of zx7r

Hello guys

I have 2000 zx-7r.

In short :
What is cause of repeated fuel pump failure of zx7r?
Is there anyone who had experienced similar trouble?

2 years ago, the engine had stopped after RPM went down while I was riding it.
Fuel was enough but I couldn't turn it on again, so I had to move it to the maintenance shop by truck.

Unfortunately, the engineer didn't know about old Kawasaki models, even he insisted that there was no fuel pump on zx7r.
But I have a friend who is 7r mania and expert, he advised me to check fuel pump whether it was OK or dead.

Thanks to him, I fixed my 7r.
I couldn't buy a genuine fuel pump of Bosch through Kawasaki, my friend got me a compatible fuel pump instead of a genuine.

I ride it a few K kilometer, maybe 1000~2000km until last Mar, and it stopped again through suffering very similar symptoms.
I tested fuel pump, and figured out that it became out of order.

When you connect a fuel pump to 12V battery directly,
Normal one : makes sounds "TARARARARARARA..."
Broken one : makes sounds "Tik"

The riding distance after last fuel pump changing was only a few K kilometers.

Anyway, I knew the pump failuer, I ordered compatible fuel pump again with few start motor relay, a fuel pump relay, too, through Ebay.
And I exchanged those 3 parts at once.

After changing those parts, my 7R run well, I rode my motorcycle to go to work yesterday morning. It was only 15 kilometers.
And last evening, when I rode it to go home, my 7R went down again! The cause was same. it was the fuel pump fail.

I still have one more extra fuel pump, but I don't think I should exchange it right now.
I guess there must be some basic electric problems, and i think I should fix it before I put a new fuel pump on it again.

1st fuel pump failuer was after almost 5K kilometer's riding.
2nd fuel pump failuer was after 1~2K kilometer's riding.
3rd fuel pump failur was after only 15 kilometer's riding.

Before last failuer, I added some flashing LED light on it's tale lamp. That's all what I did something on it.
Than flashing light doesn't even consume much electricity. it uses only few watts.

My expert friend said any additional electric equipment is not good on old motorcycle, especially 7R, so remove flashing led light first before looking for how to fix it.

I'm not sure whether it caused the trouble.

Thank you for reading.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome