ZX Forums - Reply to Topic
Thread: Lapping kit oil pump. Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-05-2019 08:32 AM
ninjanut Probably the only one on here with any experience with kit parts would be CCM. Most of us don’t have the need (racing like you) so never bother with exotic parts. Is there any other parts that need to be used in unison with the kit oil pump?
07-20-2019 10:54 AM
ritchie-t
Lapping kit oil pump.

Just wondered if anybody has fitted a new kit oil pump and it been a bit on the tight side? It feels like if I pushed it in I wouldn’t get it out again. It would be an interference fit. I know it needs to be snug, but this is too tight.

Looking at the kit manual it does say that if the kit pump is too tight then to lap the surface to make it fit. So I assume this was not uncommon back in the day.

I can always go to a machinist to get this done, but I was wondering if I am missing a trick not doing it myself. Has anybody done this? If so, I would be curious to know what method is used. With the shaft hole going through off-center it makes it a challenge to spin perfectly central.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome