ZX Forums - Reply to Topic
Thread: Need help Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-13-2019 03:02 PM
Bryondabeast I just put in a universal fuel pump matching psi to stock pump, I’ve cleaned the carbs , I’ve reset screws, I’ve cleaned gas I’ve tried seafoam . Bike jerks like I’m hitting bumps below 7k Rpms like it’s struggling. And when I gun it and let off bike acts like it’s out of fuel and idles down and dies if I don’t give it gas.
06-13-2019 07:07 AM
taildragger1197 I'd start by getting an OEM service manual. Search the ZX7 forum for a link to a free .pdf manual. There will be diagrams showing the routing of all vacuum lines and where they should be connected.
06-12-2019 06:43 PM
ninjanut Where are the vacuum lines? Where are they connected to? Post a pic if possible.
06-11-2019 09:12 PM
Bryondabeast
Need help

Just bought a 93 zx7r and cannot figure it out . Starts and runs good for 10 seconds. Then starts choking and bucking me around below 7k Rpms. Then after 7k and WOT the bike takes off. Then you let off gas and it drops and wants to shut off. I just cleaned the hell out of the carbs and set screws to 2 1/2 turns . Have two vacuum lines that having nothing connected , maybe issue? I know nothing. Can’t figure it out.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome